Bug 975647 - Hard drive spin down is set to some ridiculously short interval.
Hard drive spin down is set to some ridiculously short interval.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mate-power-manager (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-18 23:12 EDT by James
Modified: 2013-07-30 16:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-19 20:06:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James 2013-06-18 23:12:05 EDT
I can hear my drive stopping and restarting constantly. In some cases the drive was on for less than 45 seconds before stopping again, only to restart less than 5 seconds later. The drive is a brand-new 2.5in SATA drive.

Also, all my changes to the power managements settings using mate power manager are ignored.
Comment 1 James 2013-06-19 20:06:36 EDT
It seems this is a drive problem as it exists in Windows as well and it ignores 'hdparm -S 240 /dev/sda'
Comment 2 James 2013-06-19 20:12:46 EDT
WDC WD5000BPVT for the curious
Comment 3 Mykola Dvornik 2013-07-30 16:09:34 EDT
I suspect it is actually a BUG. 

My drive does the same. From 'watch hdparm -B /dev/sda' and 'watch hdparm -M /dev/sda' it is evident that tuned alters these parameters frequently and completely neglects settings in 'Gnome Disks'. Sometimes it forces too small values for the APM. 

In pre-F19, everything worked fine . So I assume that the logic behind APM adjustments has been changed in the recent versions of tuned. As the result my 'Start/Stop count' has raised by about 10k since F-19 Alpha, which is really BAD. 

The funny thing is that tuned lets HDD to spindown when music and movies are played. For sure it is because of caching, but tuned should be aware of this kind of things.

WDC WD2500BEKT-75PVMT0 (WD Scorpio Black)
tuned-2.2.2-1.fc19

Note You need to log in before you can comment on or make changes to this bug.