Bug 975673 - [Tracker] [Docs] Events main tab / sub-tabs Must Support the UI Plug-in Model
[Tracker] [Docs] Events main tab / sub-tabs Must Support the UI Plug-in Model
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
3.3.0
All Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Zac Dover
ecs-bugs
: FutureFeature
Depends On: 953989
Blocks: 978803 978804
  Show dependency treegraph
 
Reported: 2013-06-19 02:04 EDT by Andrew Burden
Modified: 2015-09-22 09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 953989
: 978803 978804 (view as bug list)
Environment:
Last Closed: 2014-04-06 21:55:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 15810 None None None Never

  None (edit)
Description Andrew Burden 2013-06-19 02:04:27 EDT
Expected to impact:
* Admin
* Dev ?


+++ This bug was initially created as a clone of Bug #953989 +++

1. Proposed title of this feature request
Event Viewer Must Support UI Plug-in Model

2. Who is the customer behind the request?
Red Hat 

3. What is the nature and description of the request?
All of the other TABs in the Webadmin console support the new UI plug-in model; however, the event viewer does not.  We need the event viewer to be plug-able so that we can diagnose the faults therein.

4. Why does the customer need this? (List the business requirements here)
Diagnostic services.

5. How would the customer like to achieve this? (List the functional requirements here)
Ensure that the admin console's event viewer is compliant with the existing plug-in model.

6. List any affected packages or components.
The Red Hat Support Plug-in for RHEV is adversely affected by the fact that the event viewer is not plug-able.

7. Would the customer be able to assist in testing this functionality if implemented?
Yes.

--- Additional comment from  on 2013-05-09 12:21:41 EDT ---

I assume this is about adding custom context-sensitive buttons/menu-items to existing Event-related tab(s).

Currently, we have addMainTabActionButton API function for main tabs. Currently, this API function doesn't support "Events" main tab, this RFE is intended to add support for this main tab:

api.addMainTabActionButton('Event', 'Button/menu-item label', {
    ...
    onClick: function() { ... },
    isEnabled: function() { ... },
    ...
});

Keith, do we also need to support adding custom context-sensitive buttons/menu-items to existing Event-related *sub* tabs? If the answer is yes, we'll have to introduce new API function for this purpose:

// Add action button to Cluster Event sub-tab
api.addSubTabActionButton('Cluster', 'Event', 'Button/menu-item label', { ... });

--- Additional comment from Spenser Shumaker on 2013-05-13 13:40:06 EDT ---

We would like to be able to add Action buttons in both main-tabs and sub-tabs.  Anywhere the user can access events, there will be value added by being able to "Diagnose" the event using our services.

--- Additional comment from  on 2013-05-15 11:53:55 EDT ---

Thanks Spenser, so we will need to improve existing addMainTabActionButton API + add new addSubTabActionButton API. Both API functions should support all table-based main/sub tabs.

--- Additional comment from  on 2013-06-17 13:07:15 EDT ---

A plugin that verifies addSubTab, addMainTabActionButton and addSubTabActionButton API functions.
Comment 1 Zac Dover 2014-04-06 21:55:16 EDT
This is an engineering bug with minimal docs impact. I suspect that it was raised for a better-to-need-it-and-not-have-it reasons.

Note You need to log in before you can comment on or make changes to this bug.