Bug 975696 - Installation on SCSI disk fails on reboot
Installation on SCSI disk fails on reboot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
s390x All
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On: 958899
Blocks: ZedoraTracker
  Show dependency treegraph
 
Reported: 2013-06-19 03:02 EDT by IBM Bug Proxy
Modified: 2013-07-16 08:09 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-16 08:09:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda log (13.92 KB, application/octet-stream)
2013-06-19 03:02 EDT, IBM Bug Proxy
no flags Details
anaconda program log (56.99 KB, application/octet-stream)
2013-06-19 03:02 EDT, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 94782 None None None Never

  None (edit)
Description IBM Bug Proxy 2013-06-19 03:02:01 EDT
== Comment: #0 - INDUSHREE GANGADHARA SHASTRY <igangadh@in.ibm.com> - 2013-06-14 01:40:55 ==
The issue is observed while installing the Feodora 19  on  zvm 

1. Attach the scsi adapter to zvm 
2. Provide all the information about the scsi disk in rd.zfcp  params files 
3. Start the installation  
4. Select the SCSI disk ..reclaim space and go for auto partition 
5. Provide the root password 
6. Once the installation completes click on reboot 


3E: HCPGSP2630I The virtual machine is placed in CP mode due to a SIGP stop and 
store status from CPU 00.                                                       
3F: HCPGSP2630I The virtual machine is placed in CP mode due to a SIGP stop and 
store status from CPU 00.                                                       
00: HCPGIR450W CP entered; disabled wait PSW 00020001 80000000 00000000 0002885E

But if you manually IPL the scsi adapter than  system comes up 
[root@r3530054 anaconda]# cat /etc/issue
Fedora release 19 (Schr?dinger?s Cat)
Kernel \r on an \m (\l)

[root@r3530054 anaconda]# cat /etc/fstab

#
# /etc/fstab
# Created by anaconda on Fri Jun 14 05:25:41 2013
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
/dev/mapper/fedora_r353005400-root /                       ext4    defaults        1 1
/dev/mapper/fedora_r353005400-boot /boot                   ext4    defaults        1 2
/dev/mapper/fedora_r353005400-swap swap                    swap    defaults        0 0
[root@r3530054 anaconda]# df -h
Filesystem                          Size  Used Avail Use% Mounted on
/dev/mapper/fedora_r353005400-root  6.3G  2.8G  3.2G  48% /
devtmpfs                            1.5G     0  1.5G   0% /dev
tmpfs                               1.5G     0  1.5G   0% /dev/shm
tmpfs                               1.5G  252K  1.5G   1% /run
tmpfs                               1.5G     0  1.5G   0% /sys/fs/cgroup
tmpfs                               1.5G  4.0K  1.5G   1% /tmp
/dev/mapper/fedora_r353005400-boot  477M   71M  381M  16% /boot
[root@r3530054 anaconda]# lszfcp -D
0.0.3c15/0x500507630508c1ae/0x402040b100000000 0:0:11:1085358112
Comment 1 IBM Bug Proxy 2013-06-19 03:02:17 EDT
Created attachment 762762 [details]
anaconda log
Comment 2 IBM Bug Proxy 2013-06-19 03:02:30 EDT
Created attachment 762763 [details]
anaconda  program log
Comment 3 Jan Stodola 2013-06-19 09:58:55 EDT
It is caused by wrong WWPN/LUN values returned by chreipl. See program.log you attached:

...
05:31:31,606 INFO program: Running... chreipl node /dev/sda
05:31:31,618 INFO program: Re-IPL type: fcp
05:31:31,619 INFO program: WWPN:        0x00500507630508c1
05:31:31,619 INFO program: LUN:         0x00402040b1000000
05:31:31,619 INFO program: Device:      0.0.3c15
05:31:31,619 INFO program: bootprog:    0
05:31:31,619 INFO program: br_lba:      0
05:31:31,619 INFO program: Bootparms:   ""
05:31:31,619 DEBUG program: Return code: 0
...

Correct values for WWPN and LUN are:
0x500507630508c1ae/0x402040b100000000

Reassigning to s390utils.

Note You need to log in before you can comment on or make changes to this bug.