Bug 975724 - There is a useless nav link on /newsletter/signup page on chrome27 with width less than 800px and IPhone4S.
There is a useless nav link on /newsletter/signup page on chrome27 with width...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Jordan Liggitt
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-19 04:31 EDT by Yujie Zhang
Modified: 2015-05-14 21:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-24 10:58:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
useless nav link (152.13 KB, image/png)
2013-06-19 04:31 EDT, Yujie Zhang
no flags Details

  None (edit)
Description Yujie Zhang 2013-06-19 04:31:36 EDT
Created attachment 762785 [details]
useless nav link

Description of problem:

Checked the newsletter sign up page on chrome27 with width less than 800px, found that there is a nav link, but with no redirect and no reponse when clicking, should remove that.

Version-Release number of selected component (if applicable):
INT(devenv_3382)

How reproducible:
always

Steps to Reproduce:
1.Go to newsletter/signup page on chrome with width less than 800px, and IPhone4S
2.
3.

Actual results:

There is a useless nav link on the page, details see in attachment please.

Expected results:

The useless nav link should be removed.

Additional info:
Comment 1 Steve Goodwin 2013-06-19 10:15:28 EDT
The issue is that our page templates include the following markup even if their is no secondary navigation associated with the page. 

<div class="column-navbar">       
          <a data-toggle="collapse" data-target=".nav-collapse" class="btn btn-navbar">
          <span class="pull-left">Navigate</span>
          <span class="pull-right">
          <span class="icon-bar"></span>
          <span class="icon-bar"></span>
          <span class="icon-bar"></span>
          </span>
          </a>
        </div>


We need a class added to such pages that can be hooked into to no display the .nav-collapse bar.
Comment 2 Jordan Liggitt 2013-06-19 10:30:49 EDT
Applies to any page without secondary nav
Comment 3 openshift-github-bot 2013-06-19 12:59:22 EDT
Commit pushed to master at https://github.com/openshift/li

https://github.com/openshift/li/commit/8485fc9191e5a2dde10f299babcae16e20fca8fd
Fix bug 975724 - don't output nav header unless there is nav content
Comment 4 Yujie Zhang 2013-06-20 06:35:05 EDT
Tested on devenv_3389, the nav link has disappeared on chrome with width less than 800px and IPhone4s, so verify this bug,thanks.

Note You need to log in before you can comment on or make changes to this bug.