Bug 975725 - Tooling always adds switchyard dependencies to new projects.
Tooling always adds switchyard dependencies to new projects.
Status: CLOSED WONTFIX
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Tooling (Show other bugs)
6.0.0
Unspecified Unspecified
low Severity high
: ---
: ---
Assigned To: Václav Chalupa
Len DiMaggio
:
Depends On: 965097
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-19 04:32 EDT by Jiri Sedlacek
Modified: 2016-09-19 21:38 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-04 08:59:18 EDT
Type: Enhancement
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Sedlacek 2013-06-19 04:32:24 EDT
If you have your own project with parent pom, where repositories are configured (or can be configured also in settings.xml), even in this case the tooling adds repositories to your project pom. 


Second issue, tooling adds dependencies on switchyard-* libraries even if you have them in your parent pom. In this case, it would be probably better to have choice to add dependencies or not (e.g. by some modal window, which shows you what will be added and you will have the choice to copy the content and add it to your parent pom, or accept the addition).
Comment 1 Brian Fitzpatrick 2013-06-21 17:20:10 EDT
We'll definitely have to investigate this further.
Comment 2 Rob Cernich 2013-08-26 11:48:09 EDT
The SwitchYard Eclipse tooling does not provide support for specifying a parent project when creating a new SwitchYard project.  Because of this, there is no way to know, during project creation, that a parent pom might be used and that it might contain dependency and repository definitions.

If we want to add the ability to specify a parent project during project creation, I think that should be a separate enhancement request and should reference this BZ.

It should be noted that if a project is configured to use a parent project, which does declare dependencies, the SwitchYard tooling should pickup that the project supports any capabilities provided by those dependencies.  The tooling should also prevent you from removing those capabilities since they are declared outside the project.

Based on all of that, I'd like to mark this as WONTFIX.
Comment 3 Rob Cernich 2013-11-11 10:41:08 EST
The request related to the repository is contained in #965097.

Updating this request to contain the enhancment to allow specification of a parent pom during project creation.
Comment 6 Brian Fitzpatrick 2015-08-04 08:59:18 EDT
Closing as WONTFIX

Note You need to log in before you can comment on or make changes to this bug.