Bug 975727 - beaker-wizard: keyerror ispatch
beaker-wizard: keyerror ispatch
Status: CLOSED DUPLICATE of bug 929190
Product: Beaker
Classification: Community
Component: command line (Show other bugs)
Unspecified Unspecified
medium Severity medium (vote)
: ---
: ---
Assigned To: Petr Šplíchal
Depends On:
  Show dependency treegraph
Reported: 2013-06-19 04:36 EDT by Karel Srot
Modified: 2018-02-05 19:41 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-06-19 04:47:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
patch that fixed it for me (2.69 KB, patch)
2013-06-19 04:49 EDT, Karel Srot
no flags Details | Diff

  None (edit)
Description Karel Srot 2013-06-19 04:36:06 EDT
Description of problem:

$ beaker-wizard -b 959460
Contacting bugzilla...
Fetching details for BZ#959460
Examining attachments for possible reproducers
Traceback (most recent call last):
  File "/usr/bin/beaker-wizard", line 9, in <module>
    load_entry_point('bkr.client==0.12.1', 'console_scripts', 'beaker-wizard')()
  File "/usr/lib/python2.6/site-packages/bkr/client/wizard.py", line 2626, in main
    test = Test(options)
  File "/usr/lib/python2.6/site-packages/bkr/client/wizard.py", line 1089, in __init__
  File "/usr/lib/python2.6/site-packages/bkr/client/wizard.py", line 2328, in init
    self.testname = Name(self.options)
  File "/usr/lib/python2.6/site-packages/bkr/client/wizard.py", line 1089, in __init__
  File "/usr/lib/python2.6/site-packages/bkr/client/wizard.py", line 1846, in init
  File "/usr/lib/python2.6/site-packages/bkr/client/wizard.py", line 1776, in fetchBugDetails
  File "/usr/lib/python2.6/site-packages/bkr/client/wizard.py", line 1911, in find
    if attachment['ispatch'] == 0 and attachment['isobsolete'] == 0:
KeyError: 'ispatch'
Comment 1 Qixiang Wan 2013-06-19 04:47:29 EDT
This is fixed in 0.13

*** This bug has been marked as a duplicate of bug 929190 ***
Comment 2 Karel Srot 2013-06-19 04:49:22 EDT
Created attachment 762794 [details]
patch that fixed it for me

Note You need to log in before you can comment on or make changes to this bug.