Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 975746 - Open port 5000
Summary: Open port 5000
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OKD
Classification: Red Hat
Component: Containers
Version: 2.x
Hardware: All
OS: Unspecified
medium
high
Target Milestone: ---
: ---
Assignee: Rob Millner
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-19 09:16 UTC by Ivar Pruijn
Modified: 2015-05-14 23:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-24 14:47:32 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ivar Pruijn 2013-06-19 09:16:30 UTC
Description of problem:

Not all commands on the Heroku toolbelt work, as port 5000 is blocked for outgoing traffic on OpenShift gears. 

Version-Release number of selected component (if applicable): -

How reproducible: Install Heroku toolbelt on a Cloud9 IDE workspace and run certain commands that require port 5000 to be open.

Steps to Reproduce:
1. Open/create a Cloud9 IDE workspace
2. Install Heroku toolbelt (https://docs.c9.io/deploying_via_cli.html)
3. Run a command like $ heroku run rake about 

Actual results:

$ heroku run rake about 

Running `rake about` attached to terminal... up, run.6283 
! Heroku client internal error. 
! Search for help at: https://help.heroku.com 
! Or report a bug at: https://github.com/heroku/heroku/issues/new 

Error: Permission denied - connect(2) (Errno::EACCES) 
Backtrace: /var/lib/stickshift/51b97f9c4382ecfddb0000ed/app-root/data/.heroku/client/lib/heroku/client/rendezvous.rb:40:in `initialize' 
/var/lib/stickshift/51b97f9c4382ecfddb0000ed/app-root/data/.heroku/client/lib/heroku/client/rendezvous.rb:40:in `open' 
/var/lib/stickshift/51b97f9c4382ecfddb0000ed/app-root/data/.heroku/client/lib/heroku/client/rendezvous.rb:40:in `block in start' 
/opt/rh/ruby193/root/usr/share/ruby/timeout.rb:69:in `timeout' 
/var/lib/stickshift/51b97f9c4382ecfddb0000ed/app-root/data/.heroku/client/lib/heroku/client/rendezvous.rb:31:in `start' 
/var/lib/stickshift/51b97f9c4382ecfddb0000ed/app-root/data/.heroku/client/lib/heroku/command/run.rb:132:in `rendezvous_session' 
/var/lib/stickshift/51b97f9c4382ecfddb0000ed/app-root/data/.heroku/client/lib/heroku/command/run.rb:119:in `run_attached' 
/var/lib/stickshift/51b97f9c4382ecfddb0000ed/app-root/data/.heroku/client/lib/heroku/command/run.rb:24:in `index' 
/var/lib/stickshift/51b97f9c4382ecfddb0000ed/app-root/data/.heroku/client/lib/heroku/command.rb:206:in `run' 
/var/lib/stickshift/51b97f9c4382ecfddb0000ed/app-root/data/.heroku/client/lib/heroku/cli.rb:28:in `start' 
/var/lib/stickshift/51b97f9c4382ecfddb0000ed/app-root/data/bin/heroku:25:in `<main>' 

Command: heroku run rake about 
Version: heroku-toolbelt/2.39.4 (x86_64-linux) ruby/1.9.3

Expected results:

Running $ heroku rake about

Additional info:

Same issue as here: https://github.com/heroku/heroku/issues/407

Comment 1 Rob Millner 2013-06-19 23:39:40 UTC
Pull request adds port 5000 to the allowed list in SELinux.

https://github.com/openshift/li/pull/1659

Comment 2 openshift-github-bot 2013-06-20 00:54:51 UTC
Commit pushed to master at https://github.com/openshift/li

https://github.com/openshift/li/commit/e217e16d2b5db36f4e252ac1615229156d67caac
Bug 975746 - Access port 5000 for heroku toolkit

Comment 3 Meng Bo 2013-06-20 05:55:17 UTC
Reproduce the issue on devenv-stage_378,

1.Create app on devenv-stage_378
2.SSH login to the app
3.
$cd app-repo/data
$export HOME=$PWD
$wget http://assets.heroku.com/heroku-client/heroku-client.tgz
$tar xzvf heroku-client.tgz
$export PATH=$PATH:$PWD/heroku-client/bin

>heroku login
Enter your Heroku credentials.
Email: bmeng@redhat.com
Password (typing will be hidden): 
Authentication successful.

>heroku apps
=== My Apps
protected-gorge-8300

>heroku run rake about --app protected-gorge-8300
Running `rake about` attached to terminal... up, run.8292
 !    Heroku client internal error.
 !    Search for help at: https://help.heroku.com
 !    Or report a bug at: https://github.com/heroku/heroku/issues/new

    Error:       Permission denied - connect(2) (Errno::EACCES)
    Backtrace:   /var/lib/openshift/500773557394547283066880/app-root/data/heroku-client/lib/heroku/client/rendezvous.rb:40:in `initialize'
                 /var/lib/openshift/500773557394547283066880/app-root/data/heroku-client/lib/heroku/client/rendezvous.rb:40:in `open'
                 /var/lib/openshift/500773557394547283066880/app-root/data/heroku-client/lib/heroku/client/rendezvous.rb:40:in `start'
                 /usr/lib/ruby/1.8/timeout.rb:67:in `timeout'
                 /var/lib/openshift/500773557394547283066880/app-root/data/heroku-client/lib/heroku/client/rendezvous.rb:31:in `start'
                 /var/lib/openshift/500773557394547283066880/app-root/data/heroku-client/lib/heroku/command/run.rb:132:in `rendezvous_session'
                 /var/lib/openshift/500773557394547283066880/app-root/data/heroku-client/lib/heroku/command/run.rb:119:in `run_attached'
                 /var/lib/openshift/500773557394547283066880/app-root/data/heroku-client/lib/heroku/command/run.rb:24:in `index'
                 /var/lib/openshift/500773557394547283066880/app-root/data/heroku-client/lib/heroku/command.rb:206:in `send'
                 /var/lib/openshift/500773557394547283066880/app-root/data/heroku-client/lib/heroku/command.rb:206:in `run'
                 /var/lib/openshift/500773557394547283066880/app-root/data/heroku-client/lib/heroku/cli.rb:28:in `start'
                 /var/lib/openshift/500773557394547283066880/app-root/data/heroku-client/bin/heroku:24

    Command:     heroku run rake about --app protected-gorge-8300
    Version:     heroku-toolbelt/2.39.4 (x86_64-linux) ruby/1.8.7


And issue fixed on devenv_3390,
In the last step,

>heroku run rake about --app protected-gorge-8300
Running `rake` attached to terminal... up, run.3576
The source :rubygems is deprecated because HTTP requests are insecure.
Please change your source to 'https://rubygems.org' if possible, or 'http://rubygems.org' if not.
rake aborted!
No Rakefile found (looking for: rakefile, Rakefile, rakefile.rb, Rakefile.rb)

(See full trace by running task with --trace)


Move bug to verified.


Note You need to log in before you can comment on or make changes to this bug.