Bug 97576 - (VM)Excessive disk activity with standard red hat 9 kernel
(VM)Excessive disk activity with standard red hat 9 kernel
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-17 17:33 EDT by Mike Hearn
Modified: 2007-04-18 12:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:41:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Hearn 2003-06-17 17:33:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030509
Mozilla Firebird/0.6 StumbleUpon/1.64

Description of problem:
I was suffering severe performance problems with extremely heavy disk IO
bringing the system to a crawl at times. This is a desktop machine btw. I
compiled a stock kernel from kernel.org, and that fixed the performance problems
(or made them more normal anyway :). 

My problem is that I work on Wine, currently for a living, so the ability to run
it is important. Without the NPTL patches, Wine is not happy (even though glibc
should disable all support for it without the kernel patches iirc). Other apps
are fine, Wine suffers bizarre lockups, odd symptoms etc that disappear when
using the standard Red Hat kernel.

So, this is to let you know of the problem (though I am not alone in seeing
this), and also an enquiry as to whether there is a way to switch off any
patches you added related to disk/vm scheduling.... or any NPTL patches I could
apply against the stock Linus kernel tree that might make Wine happier.

thanks -mike

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Use Red Hat 9 for a while. Start evo, firebird, emacs, terminals etc
2. Notice how the disk is constantly thrashing, and how switching virtual
desktops takes several seconds.
3. Compile and install 2.4.20 kernel
4. Go "aaah that's nice"
5. Realise Wine doesn't work. Go back to red hat standard kernel.
    

Actual Results:  Performance sucked.

Expected Results:  Performance should have been mind blowingly good, esp with
all those patches.

Additional info:

Athlon 1200, 2 swap partitions, 256mb memory, 800mb swap, modern 80gig hard disk.

Marking "high" because it makes the machine really unpleasant to use, very
frustrating. Feel free to lower priority if you have more pressing matters.....
Comment 1 Alan Cox 2003-06-22 13:43:41 EDT
Please provide details of the hardware
Comment 2 Mike Hearn 2003-06-23 04:15:09 EDT
FWIW I removed the "elevator" patch, and that seemed to have made things a bit
better. Still doesn't feel as responsive as the stock one though.

I gave hardware details above. In more detail:

Athlon 1200
2 swap partitions (on two separate disks)
256mb RAM (not sure exactly what type, is it relevant?)
800mb swap total
modern 80gig hard disk, connected via ATA66 I believe (the double density cables)
old 10gig hard disk, on same IDE socket as the 80gig
nVidia graphics (both drivers tried)

RH9 has the entire 80gig disk to itself. The other hard disk holds an old
Windows and SuSE install.
Comment 3 Alan Cox 2003-06-23 07:25:03 EDT
Which Red Hat kernel do you have. This is important because UDMA support for
Nvidia nforce hardware is only in the later (2.4.20-) errata.
Comment 4 Mike Hearn 2003-06-23 09:43:06 EDT
I don't have an nForce, only an nVidia graphics card.

I'm using kernel 2.4.20-18.9 (ie the latest from up2date)
Comment 5 Bugzilla owner 2004-09-30 11:41:09 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.