Bug 975787 - Seam2.3 seam.bat java.lang.ClassNotFoundException: org.apache.tools.ant.launch.Launcher on Windows
Seam2.3 seam.bat java.lang.ClassNotFoundException: org.apache.tools.ant.launc...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Seam (Show other bugs)
2.3.0
Unspecified Unspecified
unspecified Severity high
: CR1
: 2.3.0
Assigned To: Marek Novotny
Marek Schmidt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-19 07:02 EDT by Marek Schmidt
Modified: 2013-07-16 07:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-16 07:08:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBSEAM-5116 Critical Resolved seam.bat java.lang.ClassNotFoundException: org.apache.tools.ant.launch.Launcher on Windows 2013-07-16 07:08:16 EDT

  None (edit)
Description Marek Schmidt 2013-06-19 07:02:40 EDT
Description of problem:

seam-gen fails on windows with

seam.bat setup 
                        
SEAM_HOME: W:\tmp\maschmid\jboss-wfk-2.3.0.ER1\jboss-seam-2.3.1.Final-redhat-2
Using seam-gen sources from: W:\tmp\maschmid\jboss-wfk-2.3.0.ER1\jboss-seam-2.3.1.Final-redhat-2\seam-gen
java.lang.NoClassDefFoundError: org/apache/tools/ant/launch/Launcher
Caused by: java.lang.ClassNotFoundException: org.apache.tools.ant.launch.Launcher
        at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
Could not find the main class: org.apache.tools.ant.launch.Launcher.  Program will exit.
Exception in thread "main"

The problem is likely that the seam-gen library move was not updated in the seam.bat

Version-Release number of selected component (if applicable):
WFK 2.3.0.ER1
Comment 2 Marek Novotny 2013-06-19 13:12:41 EDT
fixed by https://source.jboss.org/changelog/Seam?cs=15572
Comment 4 Tomas Remes 2013-06-26 10:08:01 EDT
Verified in 2.3.0.CR1 release.
Comment 5 JBoss JIRA Server 2013-07-04 12:41:21 EDT
Marek Novotny <mnovotny@redhat.com> updated the status of jira JBSEAM-5116 to Resolved
Comment 6 JBoss JIRA Server 2013-07-04 12:41:21 EDT
Marek Novotny <mnovotny@redhat.com> made a comment on jira JBSEAM-5116

fixed

Note You need to log in before you can comment on or make changes to this bug.