Bug 975797 - Specifying virtio interface ('iface' parameter) breaks the direct backend - libguestfs hangs
Specifying virtio interface ('iface' parameter) breaks the direct backend - l...
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks: 975760 975771
  Show dependency treegraph
 
Reported: 2013-06-19 07:28 EDT by Richard W.M. Jones
Modified: 2013-06-19 12:55 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 975760
Environment:
Last Closed: 2013-06-19 12:55:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2013-06-19 07:28:58 EDT
+++ This bug was initially created as a clone of Bug #975760 +++

$ truncate -s 1G /tmp/image
$ LIBGUESTFS_BACKEND=direct \
  guestfish add-drive-ro-with-if /tmp/image virtio : run -v

libguestfs hangs (actually supermin hangs) when trying to mount
the root (appliance) disk.  The reason is that root=/dev/sdb was
passed on the kernel command line, but the actual disks present
in the appliance are:

  /dev/vda: the added disk
  /dev/sda: the appliance

libguestfs direct backend should be changed so that it doesn't
count virtio-blk disks when calculating the appliance disk's offset.

This affects libguestfs 1.20 and 1.22.
Comment 1 Richard W.M. Jones 2013-06-19 12:55:22 EDT
Fixed upstream in:
f7fe7e8db021b13f40aba56722d6ebe58e3777d2

Regression test:
d8a3185823e608dbddbc6185209951140b8f3b33

Note You need to log in before you can comment on or make changes to this bug.