Bug 975811 - OSError: [Errno 2] No such file or directory: '/dev/md'
OSError: [Errno 2] No such file or directory: '/dev/md'
Status: CLOSED DUPLICATE of bug 980267
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:ab509f68aff031a4ca35fe06b0d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-19 08:03 EDT by Dennis Gilmore
Modified: 2013-12-29 18:04 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-29 18:04:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (475.04 KB, text/plain)
2013-06-19 08:03 EDT, Dennis Gilmore
no flags Details
File: anaconda.log (5.30 KB, text/plain)
2013-06-19 08:04 EDT, Dennis Gilmore
no flags Details
File: environ (439 bytes, text/plain)
2013-06-19 08:04 EDT, Dennis Gilmore
no flags Details
File: lsblk_output (3.01 KB, text/plain)
2013-06-19 08:04 EDT, Dennis Gilmore
no flags Details
File: nmcli_dev_list (3.80 KB, text/plain)
2013-06-19 08:04 EDT, Dennis Gilmore
no flags Details
File: os_info (179 bytes, text/plain)
2013-06-19 08:04 EDT, Dennis Gilmore
no flags Details
File: program.log (38.39 KB, text/plain)
2013-06-19 08:04 EDT, Dennis Gilmore
no flags Details
File: storage.log (131.96 KB, text/plain)
2013-06-19 08:04 EDT, Dennis Gilmore
no flags Details
File: syslog (150.21 KB, text/plain)
2013-06-19 08:04 EDT, Dennis Gilmore
no flags Details
File: ifcfg.log (567 bytes, text/plain)
2013-06-19 08:04 EDT, Dennis Gilmore
no flags Details
File: packaging.log (412 bytes, text/plain)
2013-06-19 08:04 EDT, Dennis Gilmore
no flags Details

  None (edit)
Description Dennis Gilmore 2013-06-19 08:03:52 EDT
Description of problem:
I added 2 drives after system install and created a raid1 on them for /home in my setup anaconda crashes the same if run directly or from a livecd. it seems myraid array is being detected but not initialised correctly. im really not doing anything at all. if i start the install disk and wait it will crash.

Version-Release number of selected component:
anaconda-19.30.8-1

The following was filed automatically by anaconda:
anaconda 19.30.8-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devicelibs/mdraid.py", line 269, in name_from_md_node
    for link in os.listdir(md_dir):
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 2196, in resolveDevice
    md_name = devicelibs.mdraid.name_from_md_node(devspec[5:])
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 2985, in parseFSTab
    options=options)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 2908, in findExistingInstallations
    (mounts, swaps) = parseFSTab(devicetree, chroot=ROOT_PATH)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 424, in reset
    self.roots = findExistingInstallations(self.devicetree)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 144, in storageInitialize
    storage.reset()
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
OSError: [Errno 2] No such file or directory: '/dev/md'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora\x2019-TC5\x20x86_64 quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-TC5
Comment 1 Dennis Gilmore 2013-06-19 08:03:57 EDT
Created attachment 762889 [details]
File: anaconda-tb
Comment 2 Dennis Gilmore 2013-06-19 08:04:01 EDT
Created attachment 762890 [details]
File: anaconda.log
Comment 3 Dennis Gilmore 2013-06-19 08:04:06 EDT
Created attachment 762891 [details]
File: environ
Comment 4 Dennis Gilmore 2013-06-19 08:04:09 EDT
Created attachment 762892 [details]
File: lsblk_output
Comment 5 Dennis Gilmore 2013-06-19 08:04:13 EDT
Created attachment 762893 [details]
File: nmcli_dev_list
Comment 6 Dennis Gilmore 2013-06-19 08:04:16 EDT
Created attachment 762894 [details]
File: os_info
Comment 7 Dennis Gilmore 2013-06-19 08:04:20 EDT
Created attachment 762895 [details]
File: program.log
Comment 8 Dennis Gilmore 2013-06-19 08:04:23 EDT
Created attachment 762896 [details]
File: storage.log
Comment 9 Dennis Gilmore 2013-06-19 08:04:34 EDT
Created attachment 762897 [details]
File: syslog
Comment 10 Dennis Gilmore 2013-06-19 08:04:38 EDT
Created attachment 762898 [details]
File: ifcfg.log
Comment 11 Dennis Gilmore 2013-06-19 08:04:42 EDT
Created attachment 762899 [details]
File: packaging.log
Comment 12 David Lehman 2013-06-19 12:17:05 EDT
Let me guess: you have /dev/md0 in your /etc/fstab file? It is impossible for the installer to predict which minor an md array will get since your mdadm.conf is not present in the installer's runtime environment. Therefore, you must use persistent device identification in /etc/fstab, eg: UUID=, LABEL=, or name your array when you create it and specify the path using the name, eg: /dev/md/home .

This shouldn't be causing a crash, but there is little we can do about identifying an array specified as "/dev/md0" during installation.
Comment 13 Adam Williamson 2013-12-29 18:04:03 EST
Let's combine the two reports that both appear to cover the same situation (installer explodes if an mdraid array is identified by device node in fstab).

*** This bug has been marked as a duplicate of bug 980267 ***

Note You need to log in before you can comment on or make changes to this bug.