Bug 975826 - Fedora LXDE low battery warnings not showing
Fedora LXDE low battery warnings not showing
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lxpanel (Show other bugs)
18
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs, EasyFix
Depends On:
Blocks: LXDE
  Show dependency treegraph
 
Reported: 2013-06-19 08:24 EDT by Clinton Minton
Modified: 2013-07-27 21:01 EDT (History)
4 users (show)

See Also:
Fixed In Version: lxpanel-0.5.12-3.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-13 23:28:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Clinton Minton 2013-06-19 08:24:56 EDT
Description of problem:
Low battery warnings are not showing up in Fedora 18 LXDE when they are set up with LXPanel battery applet. The warnings are not being shown because the default warning system relies on xmessage(xorg-x11-apps). This is a severe problem because I set the warning system to tell me when battery is about to die and then I lose all of my work because I trusted the warning system.

Solution:
Include xorg-x11-apps by default with LXDE spin it's only 303 kB
Comment 1 Clinton Minton 2013-06-19 09:47:11 EDT
A better solution would be to use gxmessage instead of xmessage due to it having support for UTF character encoding and better options. Also would need to change default Battery applet alarm command string to use gxmessage.
Comment 2 Christoph Wickert 2013-06-20 09:22:16 EDT
I totally agree gxmessage is better, in fact I wanted to have this patched already. Thanks for the reminder.
Comment 3 Clinton Minton 2013-07-03 11:11:56 EDT
Was this able to be implemented into f19 lxde after install? The live cd still uses xmessage.
Comment 4 Christoph Wickert 2013-07-03 12:44:22 EDT
It was too late in the development cycle to get this into the livecd, I can only fix it with an update. Working on it.
Comment 5 Fedora Update System 2013-07-03 13:20:39 EDT
lxpanel-0.5.12-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/lxpanel-0.5.12-3.fc19
Comment 6 Fedora Update System 2013-07-03 13:21:20 EDT
lxpanel-0.5.12-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/lxpanel-0.5.12-3.fc18
Comment 7 Fedora Update System 2013-07-04 22:07:33 EDT
Package lxpanel-0.5.12-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lxpanel-0.5.12-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12350/lxpanel-0.5.12-3.fc19
then log in and leave karma (feedback).
Comment 8 Clinton Minton 2013-07-05 19:57:42 EDT
Thank you for the update Chris! Works great!
Comment 9 Fedora Update System 2013-07-13 23:28:18 EDT
lxpanel-0.5.12-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-07-27 21:01:52 EDT
lxpanel-0.5.12-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.