Bug 975854 - missing details in transaction error
Summary: missing details in transaction error
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-packagekit
Version: 6.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Richard Hughes
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-19 13:19 UTC by Iveta Wiedermann
Modified: 2014-05-20 10:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-05-20 10:06:07 UTC
Target Upstream Version:


Attachments (Terms of Use)
Transaction error when updating system (42.61 KB, image/png)
2013-06-19 13:19 UTC, Iveta Wiedermann
no flags Details

Description Iveta Wiedermann 2013-06-19 13:19:04 UTC
Created attachment 762950 [details]
Transaction error when updating system

Description of problem:
I ran gpk-update-viewer to install updates but I've got transaction error and after I clicked on More details, I've got incomplete information about the problem - "Multilib version problems found. This often means that the root". See screenshot in attachment.


Version-Release number of selected component (if applicable):
gnome-packagekit-2.28.3-7.el6.x86_64

How reproducible:


Steps to Reproduce:
1. Run Software Update (gpk-update-viewer)
2. Run into multilib version problems - leads to transaction error
3. Click on More details - see the text

Actual results:
Incomplete description of a problem

Expected results:
Complete description

Additional info:

Comment 1 RHEL Program Management 2013-10-13 23:28:07 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 2 Richard Hughes 2014-05-20 10:06:07 UTC
(In reply to Iveta Senfeldova from comment #0)
> I ran gpk-update-viewer to install updates but I've got transaction error
> and after I clicked on More details, I've got incomplete information about
> the problem - "Multilib version problems found. This often means that the
> root". See screenshot in attachment.

We get chunked text from yum/python in this case, and there's no real way to glue them together reliably as we already wait 50ms for each line of text. The message from yum is huge, and isn't super helpful or usually correct, so I think it's fine we don't show it.


Note You need to log in before you can comment on or make changes to this bug.