Bug 975872 - Add tests subpackage.
Add tests subpackage.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eclipse-linuxtools (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Roland Grunberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-19 09:48 EDT by Alexander Kurtakov
Modified: 2013-09-16 20:32 EDT (History)
5 users (show)

See Also:
Fixed In Version: eclipse-linuxtools-2.0.0-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 20:32:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Kurtakov 2013-06-19 09:48:32 EDT
The tests subpackage should contain the tests in linuxtools tarball in compiled form with a launcher to run them against system installed linuxtools (via rpm) and summary or the results. eclipse-tests from eclipse.srpm should be a good thing to look at for model.
Comment 1 Roland Grunberg 2013-08-09 16:20:48 EDT
I'd like to propose the running of tests with Tycho Surefire to stay as similar as we can to the way upstream does things. I've put together a small tool that takes a set of Eclipse Test Bundle jars generated from Maven/Tycho, and runs Tycho Surefire on them. This mainly required placing the manifest, pom, and .class files in the proper location. The work can be found here : http://fedorapeople.org/cgit/rgrunber/public_git/tycho-surefire-testbundlerunner.git/

I've tried this on all of linuxtools and get the same number of errors/failures as when I run tycho-surefire-plugin:test regularly on the sources. (3 failures in the SystemTap plugin) It could be possible to adapt this approach for all plugins building with Maven/Tycho that have test bundles.
Comment 2 Roland Grunberg 2013-08-09 16:53:37 EDT
Can use http://rgrunber.fedorapeople.org/eclipse-linuxtools-tests-2.0.0-3.fc20.noarch.rpm to test (should work on f19 as well).

./runAllTestBundles.sh /usr/share/eclipse/dropins/linuxtools-tests/plugins
Comment 3 Alexander Kurtakov 2013-08-12 03:24:19 EDT
Please commit it so it's built as part of every linuxtools srpm rebuild so we know we have it always and work on improving results after that.
Comment 4 Roland Grunberg 2013-08-19 09:58:49 EDT
eclipse-linuxtools-2.0.0-3 (http://koji.fedoraproject.org/koji/buildinfo?buildID=456625) now has the tests subpackage.

After some discussion, I think we've agreed that using the eclipse testing framework might be best for the time being. In the future perhaps we can make use of the functionality mentioned in Comment #1.  I've worked on a small script to make it easier to run the test bundles through the testing framework by automatically generating sane test.xml/etc. and having things work. There's only one more case to handle after which I'll post the script somewhere and package it.
Comment 5 Fedora Update System 2013-09-06 11:19:52 EDT
eclipse-linuxtools-2.0.0-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/eclipse-linuxtools-2.0.0-3.fc19
Comment 6 Fedora Update System 2013-09-06 21:30:00 EDT
Package eclipse-linuxtools-2.0.0-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing eclipse-linuxtools-2.0.0-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16021/eclipse-linuxtools-2.0.0-3.fc19
then log in and leave karma (feedback).
Comment 7 Fedora End Of Life 2013-09-16 13:08:01 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 20 development cycle.
Changing version to '20'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora20
Comment 8 Fedora Update System 2013-09-16 20:32:35 EDT
eclipse-linuxtools-2.0.0-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.