Bug 975876 - SELinux is preventing /usr/bin/bash from 'open' accesses on the chr_file /dev/pts/0.
SELinux is preventing /usr/bin/bash from 'open' accesses on the chr_file /dev...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:65c183c7bfd9195826a0e358fb3...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-19 10:00 EDT by Artur Szymczak
Modified: 2013-07-03 20:54 EDT (History)
3 users (show)

See Also:
Fixed In Version: selinux-policy-3.12.1-57.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-03 20:54:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Artur Szymczak 2013-06-19 10:00:46 EDT
Description of problem:
SELinux is preventing /usr/bin/bash from 'open' accesses on the chr_file /dev/pts/0.

*****  Plugin catchall (100. confidence) suggests  ***************************

If aby bash powinno mieć domyślnie open dostęp do 0 chr_file.
Then proszę to zgłosić jako błąd.
Można utworzyć lokalny moduł polityki, aby umożliwić ten dostęp.
Do
można tymczasowo zezwolić na ten dostęp wykonując polecenia:
# grep sandboxX.sh /var/log/audit/audit.log | audit2allow -M mojapolityka
# semodule -i mojapolityka.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:sandbox_net_t:s0:c681,c8
                              07
Target Context                unconfined_u:object_r:user_devpts_t:s0
Target Objects                /dev/pts/0 [ chr_file ]
Source                        sandboxX.sh
Source Path                   /usr/bin/bash
Port                          <Nieznane>
Host                          (removed)
Source RPM Packages           bash-4.2.45-1.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-52.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.6-301.fc19.x86_64 #1 SMP Mon
                              Jun 17 14:26:26 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-06-19 17:59:12 CEST
Last Seen                     2013-06-19 17:59:12 CEST
Local ID                      5489a4e7-dd24-40bf-8e7b-690d4d95eb81

Raw Audit Messages
type=AVC msg=audit(1371657552.400:502): avc:  denied  { open } for  pid=2239 comm="sandboxX.sh" path="/dev/pts/0" dev="devpts" ino=3 scontext=unconfined_u:unconfined_r:sandbox_net_t:s0:c681,c807 tcontext=unconfined_u:object_r:user_devpts_t:s0 tclass=chr_file


type=SYSCALL msg=audit(1371657552.400:502): arch=x86_64 syscall=open success=no exit=EACCES a0=1a91010 a1=802 a2=7fff346c1db0 a3=1 items=0 ppid=2238 pid=2239 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=2 tty=(none) comm=sandboxX.sh exe=/usr/bin/bash subj=unconfined_u:unconfined_r:sandbox_net_t:s0:c681,c807 key=(null)

Hash: sandboxX.sh,sandbox_net_t,user_devpts_t,chr_file,open

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.6-301.fc19.x86_64
type:           libreport
Comment 1 Daniel Walsh 2013-06-19 16:28:34 EDT
Seems like something we would wnat to deny.  What were you doing within the sandbox?
Comment 2 Artur Szymczak 2013-06-20 02:38:47 EDT
It happend just as I run:
# sandbox -X -t sandbox_net_t firefox

I didn't do anything more.
Comment 3 Daniel Walsh 2013-06-20 14:15:15 EDT
Seems to be something the shell is doing I guess.  Does not seem to block anything.  So I guess we can dontaudit.
Comment 4 Daniel Walsh 2013-06-20 14:30:30 EDT
Added dontaudit with

e64870f73f62a73b50818a0d46793709fb2b0a3e
5ebd8946312507def8a421b6998b6dd8a7fbcf18
Comment 5 Fedora Update System 2013-06-26 16:18:33 EDT
selinux-policy-3.12.1-57.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/selinux-policy-3.12.1-57.fc19
Comment 6 Fedora Update System 2013-06-27 11:49:03 EDT
Package selinux-policy-3.12.1-57.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.12.1-57.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11846/selinux-policy-3.12.1-57.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-07-03 20:54:57 EDT
selinux-policy-3.12.1-57.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.