Bug 975914 - llvm-ocaml-devel installs broken symlinks
llvm-ocaml-devel installs broken symlinks
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: llvm (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Včelák
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-19 11:15 EDT by Maros Zatko
Modified: 2014-01-07 04:44 EST (History)
7 users (show)

See Also:
Fixed In Version: llvm-3.3-4.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-27 00:57:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maros Zatko 2013-06-19 11:15:25 EDT
Description of problem:

One example from many:
$ file /usr/lib64/ocaml/libLLVMObjCARCOpts.a
/usr/lib64/ocaml/libLLVMObjCARCOpts.a: broken symbolic link to `/usr/lib64/llvm/libLLVMObjCARCOpts.a'


Version-Release number of selected component (if applicable):
llvm-ocaml-devel-3.3-0.6.rc3.fc19.x86_64

How reproducible:
always


Steps to Reproduce:
1. yum install llvm-ocaml-devel
2. look into /usr/lib64/ocaml/
3. observe there are broken symlinks

Actual results:
Broken symlinks to libraries.

Expected results:
Not broken symlinks and correct files in place, be able to compile things
which depends on those libraries.

Additional info:
Comment 1 Michael Schwendt 2013-08-11 07:32:09 EDT
That's due to some of the questionable packaging going on. The actual libs are found in the -static subpackage (following the Static Library Packaging Guidelines):

  %files static
  %defattr(-,root,root,-)
  %{_libdir}/%{name}/*.a

However, the symlinks and a few additional static libs are in the -ocaml-devel subpackage:

  %files ocaml-devel
  %defattr(-,root,root,-)
  %{_libdir}/ocaml/*.a
  %{_libdir}/ocaml/*.cmx*
  %{_libdir}/ocaml/*.mli
Comment 2 Jan Včelák 2013-12-19 16:25:24 EST
I do not know how devel packages for Ocaml work, but I guess llvm-ocaml-devel package should require llvm-static instead of llvm-devel. I will fix that in the next build.
Comment 3 Fedora Update System 2013-12-20 13:54:28 EST
llvm-3.3-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/llvm-3.3-4.fc19
Comment 4 Fedora Update System 2013-12-20 13:55:49 EST
llvm-3.3-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/llvm-3.3-4.fc20
Comment 5 Fedora Update System 2013-12-22 00:30:56 EST
Package llvm-3.3-4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing llvm-3.3-4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23760/llvm-3.3-4.fc19
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-12-27 00:57:41 EST
llvm-3.3-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2014-01-07 04:44:22 EST
llvm-3.3-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.