Bug 975915 - /sbin/fence_xvmd: libvirt.so.0 => not found
/sbin/fence_xvmd: libvirt.so.0 => not found
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.9
ia64 Unspecified
high Severity unspecified
: rc
: ---
Assigned To: Fabio Massimo Di Nitto
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-19 11:17 EDT by michal novacek
Modified: 2013-06-19 11:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-19 11:59:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description michal novacek 2013-06-19 11:17:28 EDT
Description of problem:
TPS found this problem: /sbin/fence_xvmd: unresolved symbols found: libvirt.so.0 => not found

Version-Release number of selected component (if applicable):
cman-2.0.115-118.el5.ia64
rhel5.9

How reproducible: always

Steps to Reproduce:
1. install rhel5.9
2. install cman
3. run 'ldd /sbin/fence_xvmd'

Actual results: libvirt.so.0 => not found

Expected results: libvirt already installed 

Additional info:
libvirt.so.0 is provided by 'libvirt' also 'libvirt-devel' is needed to rebuild cman so I do believe that there should be dependency on it. This seems to be special case for ia64.

http://lab-02.rhts.eng.bos.redhat.com/beaker/logs/tasks/13257+/13257917/tps-rpmtest.log
Comment 1 Fabio Massimo Di Nitto 2013-06-19 11:59:20 EDT
while this might sound odd, it´s not a bug.

In the RHEL5 release, the policy for _any_ fence agent was not to pull in their dependencies to avoid a full install bloat and customers are expected to take care of those themselves.

cman package is correct:

x86_64:
[root@rhel5-node2 ~]# rpm -q --requires cman |grep virt
[root@rhel5-node2 ~]# rpm -q --requires cman |grep xen 
[root@rhel5-node2 ~]# 

ia64:
[root@hp-bl870c-02 ~]# rpm -q --requires cman |grep virt
[root@hp-bl870c-02 ~]# rpm -q --requires cman |grep xen 
[root@hp-bl870c-02 ~]# 

filtering out the dependencies.

For some reasons that I am not going to investigate, x86_64 installations tend to have libvirt installed by default while ia64 no.

that makes TPS scream unnecessarily :)

Note You need to log in before you can comment on or make changes to this bug.