Bug 97594 - install fails if /usr/tmp is not symbolic link
Summary: install fails if /usr/tmp is not symbolic link
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 9
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-18 05:36 UTC by G.Wolfe Woodbury
Modified: 2007-04-18 16:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-14 16:29:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description G.Wolfe Woodbury 2003-06-18 05:36:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030529

Description of problem:
Install complains and fails hard when /usr/tmp is not a symbolic link
to ../var/tmp.

It is not inconcieveable that the local admin has reasons to use a
real /usr/tmp directory, the install should not fail if it isn't
the desired symbolic link.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. cd /usr
2. rm tmp
3. mkdir tmp
4. chmod 777 tmp; chmod +t tmp

Actual Results:  Install process complains about non-symlink and halt install

Expected Results:  no error should be found

Additional info:

Comment 1 Robert Skinner 2003-06-18 17:08:43 UTC
I get the same error when attempting to upgrade a 7.3 system to 9.0.  But my
/usr/tmp IS a link to ../var/tmp.

Are there other permissions on /usr/tmp that may be causing the failure?


Comment 2 Michael Fulbright 2003-06-18 20:27:43 UTC
#1: We do not support having /usr/tmp in any other fashion.

#2: What does ls -l say for /usr/tmp?


Comment 3 Robert Skinner 2003-06-19 05:51:27 UTC
% ls -l /usr/tmp
lrwxrwxrwx    1 root     root           10 May 13  2002 /usr/tmp -> ../var/tmp

I suppose I'll just remove the symlink if I try and upgrading again.

Comment 4 Michael Fulbright 2003-06-23 20:08:40 UTC
If you want to experiment try this:

> python
import os
print os.readlink("/usr/tmp")
<cntl-d>

and let me know what it prints out. This won't hurt any data.  This is the check
we do in anaconda.

On my system it prints "../var/tmp"


Comment 5 Robert Skinner 2003-06-26 05:07:45 UTC
% python
Python 1.5.2 (#1, Jan 31 2003, 10:58:35)  [GCC 2.96 20000731 (Red Hat Linux 
7.3 2 on linux-i386
Copyright 1991-1995 Stichting Mathematisch Centrum, Amsterdam
>>> import os
>>> print os.readlink("/usr/tmp")
../var/tmp
% 

Comment 6 G.Wolfe Woodbury 2003-06-26 05:59:47 UTC
Well, in re: #1
There are reasons that the local admin might want to have the /usr/tmp
as a real directory.  It *should* be supported.

In re #2,
I fixed the link and got the install to work.

Comment 7 Michael Fulbright 2003-07-14 16:29:15 UTC
Unfortunately because of the way upgrades/rpm work we can't change this
behavior, as it would basically break upgrades.  The filesystem package expects
this to be a symlink.


Note You need to log in before you can comment on or make changes to this bug.