Bug 975945 - VM.getStats returns balloon info in KiB which causes issues with xml-rpc int size support
VM.getStats returns balloon info in KiB which causes issues with xml-rpc int ...
Status: CLOSED DUPLICATE of bug 974917
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
Unspecified Unspecified
high Severity medium
: ---
: 3.3.0
Assigned To: Martin Sivák
sla
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-19 12:10 EDT by Martin Sivák
Modified: 2016-02-10 15:17 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-01 11:12:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Sivák 2013-06-19 12:10:53 EDT
Description of problem:

Balloon status functions (reporting) uses KiB as the unit. When the machine has more than ~2TB or memory, the number will overflow 32 bit integer and can't be transfered to engine using xml-rpc.

See https://bugzilla.redhat.com/show_bug.cgi?id=974917 for a similar bug regarding the opposite direction (where we use MiB for memory according to the code). 

Version-Release number of selected component (if applicable):

current git HEAD


Additional info:

We might need to change the reporting to use MiB units to overcome this limitation.
Comment 1 Doron Fediuck 2013-07-01 11:12:59 EDT

*** This bug has been marked as a duplicate of bug 974917 ***

Note You need to log in before you can comment on or make changes to this bug.