Bug 975955 - LVMError: lvremove failed for root: running lvm lvremove --config devices { filter=["r|/loop5$|","r|/loop6$|","r|/loop7$|"] } fedora/root failed
LVMError: lvremove failed for root: running lvm lvremove --config devices { ...
Status: CLOSED DUPLICATE of bug 975692
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:cdc7f82e6a35b2e6c4a42a4006e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-19 12:35 EDT by Kamil Páral
Modified: 2013-06-20 21:29 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-20 21:29:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (308.80 KB, text/plain)
2013-06-19 12:35 EDT, Kamil Páral
no flags Details
File: anaconda.log (10.51 KB, text/plain)
2013-06-19 12:35 EDT, Kamil Páral
no flags Details
File: environ (441 bytes, text/plain)
2013-06-19 12:35 EDT, Kamil Páral
no flags Details
File: lsblk_output (2.23 KB, text/plain)
2013-06-19 12:35 EDT, Kamil Páral
no flags Details
File: messages (140.99 KB, text/plain)
2013-06-19 12:35 EDT, Kamil Páral
no flags Details
File: nmcli_dev_list (3.36 KB, text/plain)
2013-06-19 12:35 EDT, Kamil Páral
no flags Details
File: os_info (179 bytes, text/plain)
2013-06-19 12:35 EDT, Kamil Páral
no flags Details
File: program.log (39.88 KB, text/plain)
2013-06-19 12:35 EDT, Kamil Páral
no flags Details
File: storage.log (170.01 KB, text/plain)
2013-06-19 12:35 EDT, Kamil Páral
no flags Details
File: ifcfg.log (567 bytes, text/plain)
2013-06-19 12:35 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2013-06-19 12:35:09 EDT
Description of problem:
I tried to reproduce bug 975692

Version-Release number of selected component:
anaconda-19.30.8-1.fc19.x86_64

The following was filed automatically by anaconda:
anaconda 19.30.8-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devicelibs/lvm.py", line 373, in lvremove
    raise LVMError("lvremove failed for %s: %s" % (lv_name, msg))
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2667, in _destroy
    lvm.lvremove(self.vg.name, self._name)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 821, in destroy
    self._destroy()
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 318, in execute
    self.device.destroy()
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 237, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 310, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 169, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 140, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
LVMError: lvremove failed for root: running lvm lvremove --config  devices { filter=["r|/loop5$|","r|/loop6$|","r|/loop7$|"] }  fedora/root failed

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-19-TC rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-libs-2.7.5-1.fc19.x86_64, python-blivet-0.16-1.fc19.noarch
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19
Comment 1 Kamil Páral 2013-06-19 12:35:15 EDT
Created attachment 763038 [details]
File: anaconda-tb
Comment 2 Kamil Páral 2013-06-19 12:35:19 EDT
Created attachment 763039 [details]
File: anaconda.log
Comment 3 Kamil Páral 2013-06-19 12:35:23 EDT
Created attachment 763040 [details]
File: environ
Comment 4 Kamil Páral 2013-06-19 12:35:28 EDT
Created attachment 763041 [details]
File: lsblk_output
Comment 5 Kamil Páral 2013-06-19 12:35:32 EDT
Created attachment 763042 [details]
File: messages
Comment 6 Kamil Páral 2013-06-19 12:35:37 EDT
Created attachment 763043 [details]
File: nmcli_dev_list
Comment 7 Kamil Páral 2013-06-19 12:35:41 EDT
Created attachment 763044 [details]
File: os_info
Comment 8 Kamil Páral 2013-06-19 12:35:46 EDT
Created attachment 763045 [details]
File: program.log
Comment 9 Kamil Páral 2013-06-19 12:35:50 EDT
Created attachment 763046 [details]
File: storage.log
Comment 10 Kamil Páral 2013-06-19 12:35:54 EDT
Created attachment 763047 [details]
File: ifcfg.log
Comment 11 Brian Lane 2013-06-20 21:29:10 EDT
So this is another one related to lvm snapshots. Not exactly the same error as bug 975692, but related and we already know support for this isn't working.

*** This bug has been marked as a duplicate of bug 975692 ***

Note You need to log in before you can comment on or make changes to this bug.