Bug 976038 - [abrt] general protection fault: 0000 [#1] SMP
[abrt] general protection fault: 0000 [#1] SMP
Status: CLOSED DUPLICATE of bug 975065
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:b9f00c3ed0fc76073183eda13ea...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-19 15:29 EDT by Stephen John Smoogen
Modified: 2013-06-21 08:40 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-21 08:40:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (89.83 KB, text/plain)
2013-06-19 15:29 EDT, Stephen John Smoogen
no flags Details

  None (edit)
Description Stephen John Smoogen 2013-06-19 15:29:09 EDT
Description of problem:
Trying to install RHEL-5.9 in Fedora 19 KVM was hard crashing system. Was asked to install the rawhide kernel to see if I could get debugging information on what happens. Booted kernel-3.10.0 and got the following oops when RHEL-5.9 booted in KVM.

Additional info:
reporter:       libreport-2.1.5
general protection fault: 0000 [#1] SMP 
Modules linked in: vhost_net macvtap macvlan ebtable_nat xt_CHECKSUM tun bridge stp llc rfcomm bnep nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_nat nf_nat_ipv6 ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables vfat fat snd_hda_codec_hdmi snd_hda_codec_conexant mperf coretemp snd_hda_intel kvm_intel arc4 iwldvm kvm snd_hda_codec snd_hwdep mac80211 sdhci_pci sdhci snd_seq snd_seq_device snd_pcm iTCO_wdt iTCO_vendor_support btusb mmc_core uvcvideo videobuf2_vmalloc videobuf2_memops iwlwifi videobuf2_core videodev bluetooth e1000e media lpc_ich thinkpad_acpi ptp cfg80211 wmi snd_page_alloc snd_timer pps_core microcode snd i2c_i801 mfd_core rfkill soundcore binfmt_misc uinput dm_crypt crc32_pclmul crc32c_intel ghash_clmulni_intel usb_storage i915 firewire_ohci firewire_core i2c_algo_bit drm_kms_helper crc_itu_t drm i2c_core video hid_logitech_dj
CPU: 1 PID: 12407 Comm: qemu-system-x86 Not tainted 3.10.0-0.rc6.git0.4.fc20.x86_64 #1
Hardware name: LENOVO 4243B37/4243B37, BIOS 8AET56WW (1.36 ) 12/06/2011
task: ffff88020a2626e0 ti: ffff88016db1c000 task.ti: ffff88016db1c000
RIP: 0010:[<ffffffff810d9b49>]  [<ffffffff810d9b49>] __lock_acquire+0x1b9/0x1b30
RSP: 0018:ffff88016db1dc20  EFLAGS: 00010002
RAX: 6b6b6b6b6b6b6b6b RBX: 0000000000000002 RCX: 0000000000000000
RDX: 0000000000000000 RSI: 0000000000000000 RDI: ffff88019a5b3758
RBP: ffff88016db1dcd0 R08: 0000000000000002 R09: 0000000000000001
R10: 0000000000000000 R11: 0000000000000000 R12: ffff88020a2626e0
R13: 6b6b6b6b6b6b6b6b R14: ffff88019a5b3758 R15: 0000000000000000
FS:  00007ff4a129c700(0000) GS:ffff880214e00000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: 00007ff49c02e000 CR3: 000000016dc5e000 CR4: 00000000000427e0
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Stack:
 ffff88020a2626e0 0000000000000002 ffff88020a2626e0 0000000000000696
 ffff88016daa44c0 0000000000000001 ffff88016db1dd10 0000000000000046
 0000000000000006 0000000000000006 ffff88020a2626e0 ffff88016db1dcb8
Call Trace:
 [<ffffffff81714cf4>] ? __slab_free+0x1b5/0x38b
 [<ffffffff810dbcb2>] lock_acquire+0xa2/0x1f0
 [<ffffffff810a1f73>] ? __wake_up+0x23/0x50
 [<ffffffff8171f52e>] _raw_spin_lock_irqsave+0x5e/0xa0
 [<ffffffff810a1f73>] ? __wake_up+0x23/0x50
 [<ffffffff810a1f73>] __wake_up+0x23/0x50
 [<ffffffffa07053de>] vhost_net_zerocopy_done_signal+0x1e/0x20 [vhost_net]
 [<ffffffffa0705f53>] vhost_net_ubuf_put_and_wait+0x23/0xa0 [vhost_net]
 [<ffffffffa0706045>] vhost_net_flush+0x75/0xa0 [vhost_net]
 [<ffffffffa07069a2>] vhost_net_ioctl+0x122/0x7e0 [vhost_net]
 [<ffffffff812ed656>] ? inode_has_perm.isra.49.constprop.65+0x56/0x80
 [<ffffffff811ef565>] do_vfs_ioctl+0x305/0x530
 [<ffffffff812eda3b>] ? selinux_file_ioctl+0x5b/0x110
 [<ffffffff811ef811>] SyS_ioctl+0x81/0xa0
 [<ffffffff81728b19>] system_call_fastpath+0x16/0x1b
Code: a1 81 be fb 0b 00 00 48 c7 c7 9f ea a1 81 31 c0 e8 5d da f8 ff eb a3 0f 1f 00 44 89 fa 4d 8b 6c d6 08 4d 85 ed 0f 84 c3 fe ff ff <f0> 41 ff 85 98 01 00 00 8b 05 61 4c 07 01 45 8b bc 24 e8 08 00 
RIP  [<ffffffff810d9b49>] __lock_acquire+0x1b9/0x1b30
 RSP <ffff88016db1dc20>
Comment 1 Stephen John Smoogen 2013-06-19 15:29:14 EDT
Created attachment 763124 [details]
File: dmesg
Comment 2 Josh Boyer 2013-06-21 08:40:26 EDT
Smooge tested this kernel yesterday successfully:

http://koji.fedoraproject.org/koji/taskinfo?taskID=5523794

I'm going to dup this to 975065 which is where we're tracking this one mostly.

*** This bug has been marked as a duplicate of bug 975065 ***

Note You need to log in before you can comment on or make changes to this bug.