Bug 976056 - rpm repo remove lists synchronized packages as removed even though they are not
rpm repo remove lists synchronized packages as removed even though they are not
Status: CLOSED DUPLICATE of bug 916977
Product: Pulp
Classification: Community
Component: rpm-support (Show other bugs)
2.2 Beta
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Randy Barlow
Preethi Thomas
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-19 16:05 EDT by Jeremy Cline
Modified: 2013-08-11 21:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-20 13:14:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Cline 2013-06-19 16:05:22 EDT
Description of problem: 'pulp-admin rpm repo remove' does not (and should not) remove sync'd packages, but when the command is run the sync'd packages appear in the list of removed units.


Version-Release number of selected component (if applicable): pulp-rpm-admin-extensions-2.2.0-0.4.beta.fc18.noarch


How reproducible: always


Steps to Reproduce:
1. pulp-admin rpm repo create --repo-id=zoo --feed=http://repos.fedorapeople.org/repos/pulp/pulp/demo_repos/zoo/
2. pulp-admin rpm repo sync run --repo-id=zoo
3. pulp-admin rpm repo remove rpm --repo-id=zoo --str-eq='release=1'
4. pulp-admin rpm repo content rpm --repo-id=zoo --str-eq='release=1'

Actual results: The packages are listed as removed, but aren't


Expected results: the packages should not be listed as removed. 


Additional info:
Comment 1 Preethi Thomas 2013-06-20 13:14:36 EDT

*** This bug has been marked as a duplicate of bug 916977 ***

Note You need to log in before you can comment on or make changes to this bug.