Bug 976074 - it is not possible to upload drpm files with rpm repo uploads
it is not possible to upload drpm files with rpm repo uploads
Status: CLOSED UPSTREAM
Product: Pulp
Classification: Community
Component: rpm-support (Show other bugs)
2.2 Beta
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: pulp-bugs
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-19 16:32 EDT by Jeremy Cline
Modified: 2015-02-28 16:57 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-28 16:57:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Pulp Redmine 360 None None None Never

  None (edit)
Description Jeremy Cline 2013-06-19 16:32:49 EDT
Description of problem: rpm content can be uploaded (and source rpms with rpm), but delta rpms cannot be uploaded. Since there are seperate sections for drpm, srpm, and rpm in remove and content, I expected the same in uploads.


Version-Release number of selected component (if applicable): pulp-rpm-admin-extensions-2.2.0-0.4.beta.fc18.noarch


How reproducible: always


Steps to Reproduce:
1. Create an rpm repo and try and upload some drpm files with rpm repo uploads.


Actual results: there is no section for drpm and rpm does not handle them. It does handle srpm, but they are placed under rpm and an arch of 'src'. Probably because srpm format is name-version.platform.src.rpm and drpm is name-version.platform.arch.drpm. 


Expected results: The ability to upload drpm (and srpm correctly) with rpm repo uploads


Additional info:
Comment 1 Michael Hrivnak 2013-06-21 11:14:10 EDT
this will not come any sooner than we can re-do the yum distributor.
Comment 3 Brian Bouterse 2015-02-28 16:57:22 EST
Moved to https://pulp.plan.io/issues/360

Note You need to log in before you can comment on or make changes to this bug.