Bug 97609 - Japanese app-default file installation
Summary: Japanese app-default file installation
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: xemacs-sumo   
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-18 12:11 UTC by Takanori MATSUURA
Modified: 2015-01-08 00:05 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-27 09:24:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diff of spec file (1.32 KB, patch)
2003-06-18 12:12 UTC, Takanori MATSUURA
no flags Details | Diff

Description Takanori MATSUURA 2003-06-18 12:11:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030613

Description of problem:
On install stage of rpmbuild,

1. directory for Japanese app-default file is not created.

2. app-default files are installed at
   /usr/X11R6/lib/X11/$(lang)/app-defaults/Emacs and symlinks from
   /usr/share/xemacs/mule-packages/etc/app-defaults/$(lang)/Emacs to
   those files are created. But these symlinks is not needed now.

So spec file should be changed as the following attachment.

Version-Release number of selected component (if applicable):
xemacs-21.4.13-2

How reproducible:
Always

Steps to Reproduce:
1. build xemacs package

Actual Results:  Error occurs when Japanese app-default file installation

Expected Results:  Japanese app-default file is installed successfully

Comment 1 Takanori MATSUURA 2003-06-18 12:12:48 UTC
Created attachment 92459 [details]
diff of spec file

Comment 2 Jens Petersen 2003-06-19 01:56:44 UTC
Ok, I'm aware some of the symlinks get overwritten, but not all of them do.
So I think it is easier just to leave it as it is now.

Thanks for the report.

Are you worrying about the lack of Japanese menus now?
This is because of the move to UTF-8.

Comment 3 Jens Petersen 2003-07-22 12:14:14 UTC
Sorry, what is the error during "Japanese app-default file installation"?

Comment 4 Jens Petersen 2003-12-27 09:24:30 UTC
app-default files are not longer being installed under
/usr/X11R6/lib/X11.


Note You need to log in before you can comment on or make changes to this bug.