Bug 976093 - BootLoaderError: failed to remove old efi boot entry
BootLoaderError: failed to remove old efi boot entry
Status: CLOSED DUPLICATE of bug 975537
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:9c9dc17ec6012fec3ebd0112628...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-19 17:32 EDT by Chris Murphy
Modified: 2013-06-19 17:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-19 17:38:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda-tb (1.04 MB, text/plain)
2013-06-19 17:39 EDT, Chris Murphy
no flags Details
dmesg (118.51 KB, text/plain)
2013-06-19 17:46 EDT, Chris Murphy
no flags Details
program.log (137.34 KB, text/plain)
2013-06-19 17:53 EDT, Chris Murphy
no flags Details
messages (389.63 KB, text/plain)
2013-06-19 17:55 EDT, Chris Murphy
no flags Details

  None (edit)
Description Chris Murphy 2013-06-19 17:32:56 EDT
Description of problem:
Installation of F18 with an existing F19 Fedora entry in NVRAM.
The following was filed automatically by anaconda:
anaconda 18.37.11 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1640, in remove_efi_boot_target
    raise BootLoaderError("failed to remove old efi boot entry")
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1669, in install
    self.remove_efi_boot_target()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1705, in install
    super(MacEFIGRUB, self).install()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1689, in write
    self.install()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 2312, in writeBootLoader
    storage.bootloader.write()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 135, in doInstall
    writeBootLoader(storage, payload, instClass, ksdata)
  File "/usr/lib64/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 91, in run
    threading.Thread.run(self, *args, **kwargs)
BootLoaderError: failed to remove old efi boot entry

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-18-x86_64-Live-Desktop.is ro rd.live.image quiet rhgb
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.6.10-4.fc18.x86_64
other involved packages: python-libs-2.7.3-13.fc18.x86_64
package:        anaconda-18.37.11-1.fc18.x86_64
product:        Fedora
release:        Fedora release 18 (Spherical Cow)
type:           libreport
version:        18
Comment 1 Chris Murphy 2013-06-19 17:38:55 EDT

*** This bug has been marked as a duplicate of bug 975537 ***
Comment 2 Chris Murphy 2013-06-19 17:39:40 EDT
Created attachment 763142 [details]
anaconda-tb
Comment 3 Chris Murphy 2013-06-19 17:46:46 EDT
Created attachment 763143 [details]
dmesg

This occurs at the same time anaconda crashes.

[  464.615665] efivars: DataSize & Attributes must be valid!
Comment 4 Chris Murphy 2013-06-19 17:53:08 EDT
Created attachment 763146 [details]
program.log

log ends with this entry:
17:25:17,318 INFO program: Running... efibootmgr -b 0000 -B
Comment 5 Chris Murphy 2013-06-19 17:55:09 EDT
Created attachment 763147 [details]
messages

Note You need to log in before you can comment on or make changes to this bug.