Bug 976107 - gnome-games 17 to 19 update fails
gnome-games 17 to 19 update fails
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-games (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
AcceptedFreezeException
:
Depends On:
Blocks: F19-accepted/F19FinalFreezeException
  Show dependency treegraph
 
Reported: 2013-06-19 19:33 EDT by Pete Walter
Modified: 2013-06-21 22:31 EDT (History)
7 users (show)

See Also:
Fixed In Version: five-or-more-3.8.2-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-21 22:31:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Walter 2013-06-19 19:33:31 EDT
Description of problem:
Updating Fedora 17 to Fedora 19 fails with gnome-games dependency errors.

Error: Package: 1:gnome-games-3.4.1-2.fc17.x86_64 (@koji-override-0/$releasever)
           Requires: libcogl-pango.so.0()(64bit)
           Removing: cogl-1.10.2-1.fc17.x86_64 (@koji-override-0/$releasever)
               libcogl-pango.so.0()(64bit)
           Updated By: cogl-1.14.0-3.fc19.x86_64 (fedora)
               Not found
Error: Package: 1:gnome-games-3.4.1-2.fc17.x86_64 (@koji-override-0/$releasever)
           Requires: libcogl.so.9()(64bit)
           Removing: cogl-1.10.2-1.fc17.x86_64 (@koji-override-0/$releasever)
               libcogl.so.9()(64bit)
           Updated By: cogl-1.14.0-3.fc19.x86_64 (fedora)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Version-Release number of selected component (if applicable):
1:gnome-games-3.4.1-2.fc17.x86_64

How reproducible:
Always


Steps to Reproduce:
1. Install 17
2. yum update --releasever=19
3. Waah

Actual results:
Update failure


Expected results:
Update succeeds


Additional info:
17 to 18 update works.
18 to 19 update works.
Comment 1 Fedora Blocker Bugs Application 2013-06-19 19:37:30 EDT
Proposed as a Blocker and Freeze Exception for 19-final by Fedora user pwalter using the blocker tracking app because:

 17 to 19 update fails. No customizations made, only default install where updating has to work.
Comment 2 Mathieu Bridon 2013-06-19 22:26:26 EDT
The gnome-games package doesn't exist any more in Fedora 19. [1]

As a result, your Fedora 17 package doesn't get updated, it stays as it is on your system, and prevents the rest of the upgrade.

Not sure there's anything we can do about it...


[1] https://fedorahosted.org/rel-eng/ticket/5614
Comment 3 Adam Williamson 2013-06-19 22:58:08 EDT
"Not sure there's anything we can do about it..."

Sure there is. Something should obsolete it.
Comment 4 Mathieu Bridon 2013-06-19 23:55:50 EDT
(In reply to Adam Williamson from comment #3)
> "Not sure there's anything we can do about it..."
> 
> Sure there is. Something should obsolete it.

So in Fedora 17, the gnome-games package contains the following games:
- Gnomine
- Iagno
- Sudoku
- Swell Foop

In Fedora 18, we split them up into independent subpackages:
- gnome-games-gnomine
- gnome-games-iagno
- gnome-games-sudoku
- gnome-games-swell-foop

And indeed, these all contained:
 Obsoletes: gnome-games < %{gnome_games_split_version}

(where %{gnome_games_split_version} is the first build which got split into individual subpackages)

In Fedora 19, these are provided by the following packages:

- gnome-mines
- iagno
- gnome-sudoku
- swell-foop

I guess these could gain an Obsoletes.

But will the 4 of them actually get installed to replace the single gnome-games package? If not, the users will find themselves with some games removed after an upgrade...

In any case, this bug should then be cloned to each of the above 4 packages if you want them to gain an Obsoletes on gnome-games.
Comment 5 Adam Williamson 2013-06-20 00:01:01 EDT
AIUI, if you set four packages to each obsolete one package, then all four will be installed to replace that one, yes. Cloning off four bugs seems like more work than just doing the damn obsoletes myself, so do you mind if I do that instead? :P
Comment 6 Fedora Update System 2013-06-20 00:20:58 EDT
swell-foop-3.8.1-3.fc19,iagno-3.8.1-3.fc19,gnome-mines-3.8.1-2.fc19,gnome-sudoku-3.8.1-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/swell-foop-3.8.1-3.fc19,iagno-3.8.1-3.fc19,gnome-mines-3.8.1-2.fc19,gnome-sudoku-3.8.1-2.fc19
Comment 7 Kamil Páral 2013-06-20 08:19:55 EDT
I'd like to note that our criteria say only F18->F19 upgrade issues are blockers:
" For each one of the release-blocking package sets ('minimal', and the package sets for each one of the release-blocking desktops), it must be possible to successfully complete an upgrade from a fully updated installation of the previous stable Fedora release with that package set installed, using all officially recommended upgrade mechanisms. The upgraded system must meet all release criteria "
http://fedoraproject.org/wiki/Fedora_19_Final_Release_Criteria
Comment 8 Fedora Update System 2013-06-20 13:57:16 EDT
Package swell-foop-3.8.1-3.fc19, iagno-3.8.1-3.fc19, gnome-mines-3.8.1-2.fc19, gnome-sudoku-3.8.1-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing swell-foop-3.8.1-3.fc19 iagno-3.8.1-3.fc19 gnome-mines-3.8.1-2.fc19 gnome-sudoku-3.8.1-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11313/swell-foop-3.8.1-3.fc19,iagno-3.8.1-3.fc19,gnome-mines-3.8.1-2.fc19,gnome-sudoku-3.8.1-2.fc19
then log in and leave karma (feedback).
Comment 9 Adam Williamson 2013-06-20 22:09:40 EDT
Discussed at 2013-06-20 blocker: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-06-20/f19final-blocker-review-7.1.2013-06-20-15.01.html . Accepted as a blocker per criterion "All known bugs that can cause corruption of user data must be fixed or documented at Common F19 bugs". Rejected as a blocker bug as direct N-2 to N upgrades are explicitly not 'supported' by the criterion, but accepted as a freeze exception as we like to fix them if possible.

(I'll make a side note here that blocker/FE status only makes any sense at all as regards media-based upgrades, and I'm not actually sure that they work at all with fedup yet. We should really test and clarify that. For repo-based upgrades, it really doesn't matter whether we put the fix through the freeze or not).
Comment 10 Adam Williamson 2013-06-20 22:12:13 EDT
Er, the previous comment had a copy/paste fail which made it completely incomprehensible. For clarity's sake, this is what the first paragraph should have said:

Discussed at 2013-06-20 blocker: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-06-20/f19final-blocker-review-7.1.2013-06-20-15.01.html . Rejected as a blocker bug as direct N-2 to N upgrades are explicitly not 'supported' by the criterion, but accepted as a freeze exception as we like to fix them if possible.
Comment 11 Adam Williamson 2013-06-21 17:47:18 EDT
I just tested a 'yum distro-sync' from F17 with the update. Looks like there's one issue remaining:

Error: Package: 1:gnome-games-help-3.4.2-2.fc17.noarch (@updates/17)
           Requires: gnome-games = 1:3.4.2-2.fc17
           Removing: 1:gnome-games-3.4.2-2.fc17.x86_64 (@updates/17)
               gnome-games = 1:3.4.2-2.fc17
           Obsoleted By: swell-foop-3.8.1-3.fc19.x86_64 (side)
               Not found
Comment 12 Fedora Update System 2013-06-21 21:14:44 EDT
Package five-or-more-3.8.2-2.fc19, four-in-a-row-3.8.1-2.fc19, gnome-chess-3.8.3-2.fc19, gnome-klotski-3.8.2-2.fc19, gnome-mahjongg-3.8.0-3.fc19, gnome-mines-3.8.1-3.fc19, gnome-nibbles-3.8.0-2.fc19, gnome-robots-3.8.1-3.fc19, gnome-sudoku-3.8.1-3.fc19, gnome-tetravex-3.8.1-2.fc19, iagno-3.8.1-4.fc19, lightsoff-3.8.0-2.fc19, quadrapassel-3.8.1-2.fc19, swell-foop-3.8.1-4.fc19, tali-3.8.0-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing five-or-more-3.8.2-2.fc19 four-in-a-row-3.8.1-2.fc19 gnome-chess-3.8.3-2.fc19 gnome-klotski-3.8.2-2.fc19 gnome-mahjongg-3.8.0-3.fc19 gnome-mines-3.8.1-3.fc19 gnome-nibbles-3.8.0-2.fc19 gnome-robots-3.8.1-3.fc19 gnome-sudoku-3.8.1-3.fc19 gnome-tetravex-3.8.1-2.fc19 iagno-3.8.1-4.fc19 lightsoff-3.8.0-2.fc19 quadrapassel-3.8.1-2.fc19 swell-foop-3.8.1-4.fc19 tali-3.8.0-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11313/five-or-more-3.8.2-2.fc19,four-in-a-row-3.8.1-2.fc19,gnome-chess-3.8.3-2.fc19,gnome-klotski-3.8.2-2.fc19,gnome-mahjongg-3.8.0-3.fc19,gnome-mines-3.8.1-3.fc19,gnome-nibbles-3.8.0-2.fc19,gnome-robots-3.8.1-3.fc19,gnome-sudoku-3.8.1-3.fc19,gnome-tetravex-3.8.1-2.fc19,iagno-3.8.1-4.fc19,lightsoff-3.8.0-2.fc19,quadrapassel-3.8.1-2.fc19,swell-foop-3.8.1-4.fc19,tali-3.8.0-2.fc19
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2013-06-21 22:31:28 EDT
five-or-more-3.8.2-2.fc19, four-in-a-row-3.8.1-2.fc19, gnome-chess-3.8.3-2.fc19, gnome-klotski-3.8.2-2.fc19, gnome-mahjongg-3.8.0-3.fc19, gnome-mines-3.8.1-3.fc19, gnome-nibbles-3.8.0-2.fc19, gnome-robots-3.8.1-3.fc19, gnome-sudoku-3.8.1-3.fc19, gnome-tetravex-3.8.1-2.fc19, iagno-3.8.1-4.fc19, lightsoff-3.8.0-2.fc19, quadrapassel-3.8.1-2.fc19, swell-foop-3.8.1-4.fc19, tali-3.8.0-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.