Bug 976111 - RFE: Protect content specs from manual editing
RFE: Protect content specs from manual editing
Status: CLOSED WONTFIX
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
1.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: pressgang-ccms-dev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-19 19:58 EDT by Joshua Wulf
Modified: 2014-10-19 19:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-31 23:52:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2013-06-19 19:58:54 EDT
Description of problem:

At the moment users can edit content specs in the web editor with no validation. This results in broken content specs. It's especially a problem for new users, because they rightly expect that the system would not allow them to do something that would break their stuff without warning them.

Solution:

The immediate solution should be to make content specs read-only in the web editor. It can be done trivially with JavaScript:

if (topic.isContentSpec()) makeEditorReadOnly();

If you wanted to make it user friendly, you could put a link to the death star content spec editor, a GUI wrapper for the content spec processor, while you are waiting for your own web-based solution. Otherwise, a notice telling them to use the csprocessor to edit the spec (please- no modal dialogs! :-) would be good.
Comment 1 Lee Newson 2013-08-31 23:52:30 EDT
Closing this as won't fix since we will be moving to the new editor very shortly. If anyone tries to edit an old content spec topic in the editor then they will be prompted to use the new editor.

Note You need to log in before you can comment on or make changes to this bug.