Bug 976246 - Misleading description about database connectors
Misleading description about database connectors
Status: CLOSED CURRENTRELEASE
Product: Red Hat Software Collections
Classification: Red Hat
Component: doc-Release_Notes (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.0
Assigned To: Eliska Slobodova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-20 04:16 EDT by Petr Šplíchal
Modified: 2016-05-31 21:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-26 07:22:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Šplíchal 2013-06-20 04:16:17 EDT
Document URL: 
https://access.redhat.com/site/documentation/en-US/Red_Hat_Software_Collections/1-Beta/html-single/1.0_Release_Notes/index.html

Section Number and Name:
2.2. Known Issues

Describe the issue: 
The paragraph describing the databases mentions that RHSCL does
not include database connectors. This might be misleading as there
are db connectors available for python/php/perl.

The text in question:
Red Hat Software Collections does not include database connectors;
client libraries packaged in the Red Hat Software Collections
database packages are not supposed to be used as they are included
only for purposes of server utilities and the daemon. Users are
instead expected to use the system libraries and database
connectors provided with the core system.
Comment 2 Bohuslav "Slavek" Kabrda 2013-06-21 09:32:00 EDT
Speaking for Python collections, python27 has connectors to mysql and postgres, python33 has connector for postgres. Both also have the Python-builtin connector to sqlite, but since that one is built into Python, I think it's not needed to be mentioned.
Comment 3 Eliska Slobodova 2013-06-26 07:22:28 EDT
The description has been corrected and the book republished; closing.
Comment 4 Bohuslav "Slavek" Kabrda 2013-07-08 05:45:39 EDT
I can still see the errors I mentioned: [1] Is this the official documentation that should be correct (also please note that you spell PostgreSQL without "t", that should be corrected as well).

Thanks.

[1] https://access.redhat.com/site/documentation//en-US/Red_Hat_Software_Collections/1-Beta/html/1.0_Release_Notes/chap-RHSCL.html#sect-RHSCL-Features

Note You need to log in before you can comment on or make changes to this bug.