Bug 976278 - Restarting Satellite with opened browser session causes traceback
Restarting Satellite with opened browser session causes traceback
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
560
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Lestach
Pavel Studeník
:
Depends On:
Blocks: sat560-lowbug
  Show dependency treegraph
 
Reported: 2013-06-20 05:23 EDT by Jiří Mikulka
Modified: 2014-10-06 09:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:55:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiří Mikulka 2013-06-20 05:23:26 EDT
Description of problem:
Restarting Satellite when there's an opened browser session leads to traceback in catalina.out.

Version-Release number of selected component (if applicable):
Satellite-5.6.0-RHEL6-re20130617.0
spacewalk-java-1.9.83-45.el6sat.noarch

How reproducible:
always

Steps to Reproduce:
1. log into Satellite
2. tail -f /var/log/tomcat6/catalina.out
3. rhn-satellite restart
4. check catalina.out

Actual results:
SEVERE: IOException while loading persisted sessions: java.io.WriteAbortedException: writing aborted; java.io.NotSerializableException: com.redhat.rhn.common.db.datasource.CachedStatement
Throwable occurred: java.io.WriteAbortedException: writing aborted; java.io.NotSerializableException: com.redhat.rhn.common.db.datasource.CachedStatement
	at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1339)
	at java.io.ObjectInputStream.readObject(ObjectInputStream.java:354)
	at java.util.ArrayList.readObject(ArrayList.java:731)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:48)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
...

Expected results:
There's no traceback in logs.

Additional info:
May be related or similar to bug 468232.
Comment 1 Tomas Lestach 2013-06-25 04:37:52 EDT
This issue was already fixed in upstream ...

spacewalk.git: c3bdbe6ebfc88838cbfa7db124e17d14cc5480e2
Comment 4 Clifford Perry 2013-10-01 17:55:10 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.