Bug 976292 - statedump crashes in ioc_inode_dump
statedump crashes in ioc_inode_dump
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.1
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Raghavendra G
Sachidananda Urs
:
Depends On: 976189
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-20 05:59 EDT by Raghavendra G
Modified: 2013-09-23 18:35 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.12rhs.beta5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 976189
Environment:
Last Closed: 2013-09-23 18:35:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raghavendra G 2013-06-20 05:59:54 EDT
+++ This bug was initially created as a clone of Bug #976189 +++

Description of problem:
spinlock 1
epoll.h 1
xattr.h 1
st_atim.tv_nsec 1
package-string: glusterfs 3.3git
/lib64/libc.so.6[0x3479e32920]
/lib64/libc.so.6(gsignal+0x35)[0x3479e328a5]
/lib64/libc.so.6(abort+0x175)[0x3479e34085]
/lib64/libc.so.6[0x3479e2ba1e]
/lib64/libc.so.6(__assert_perror_fail+0x0)[0x3479e2bae0]
/usr/local/lib/libglusterfs.so.0(__inode_path+0x8e)[0x7f59ac0fd092]
/usr/local/lib/glusterfs/3.3git/xlator/performance/io-cache.so(ioc_inode_dump+0x14e)[0x7f59a6de2d91]
/usr/local/lib/libglusterfs.so.0(inode_dump+0x2d1)[0x7f59ac0fe407]
/usr/local/lib/libglusterfs.so.0(inode_table_dump+0x2ac)[0x7f59ac0fe6fb]
/usr/local/lib/glusterfs/3.3git/xlator/debug/io-stats.so(ios_itable_dump+0x39)[0x7f59a67a5cf0]
/usr/local/lib/libglusterfs.so.0(gf_proc_dump_xlator_info+0x169)[0x7f59ac11db86]
/usr/local/lib/libglusterfs.so.0(gf_proc_dump_info+0x4e0)[0x7f59ac11e89a]
/usr/local/sbin/glusterfs(glusterfs_sigwaiter+0x11a)[0x4082a9]
/lib64/libpthread.so.0[0x347a607851]
/lib64/libc.so.6(clone+0x6d)[0x3479ee890d]
---------


Version-Release number of selected component (if applicable):


How reproducible:
This is itermittent

Steps to Reproduce:
1. Untar linux kernel in a loop
2. take statedump of the mount every 2 hours
3.

Actual results:


Expected results:


Additional info:
It is debatable whether itable dumping should happen even for inodes that are not yet linked. So the fix may happen even there.

--- Additional comment from Anand Avati on 2013-06-20 04:41:39 EDT ---

REVIEW: http://review.gluster.org/5241 (performance/io-cache: check for non-null gfid before calling inode_path) posted (#1) for review on master by Raghavendra G (raghavendra@gluster.com)

--- Additional comment from Anand Avati on 2013-06-20 05:22:29 EDT ---

REVIEW: http://review.gluster.org/5241 (performance/io-cache: check for non-null gfid before calling inode_path) posted (#2) for review on master by Raghavendra G (raghavendra@gluster.com)

--- Additional comment from Anand Avati on 2013-06-20 05:24:42 EDT ---

REVIEW: http://review.gluster.org/5241 (performance/io-cache: check for non-null gfid before calling inode_path) posted (#3) for review on master by Raghavendra G (raghavendra@gluster.com)
Comment 3 Sachidananda Urs 2013-08-02 02:09:31 EDT
Verified on: glusterfs 3.4.0.14rhs built on Jul 30 2013 09:09:36

No crash seen.
Comment 4 Scott Haines 2013-09-23 18:35:38 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.