Bug 976304 - Inserting and editing of objects from the gallery mostly fails
Inserting and editing of objects from the gallery mostly fails
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-20 06:21 EDT by Joachim Backes
Modified: 2013-06-29 14:18 EDT (History)
6 users (show)

See Also:
Fixed In Version: libreoffice-4.1.0.1-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-29 14:18:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screencasting what i did (1.73 MB, video/webm)
2013-06-20 09:01 EDT, Joachim Backes
no flags Details
All the extensions I installed (72.39 KB, image/png)
2013-06-20 14:01 EDT, Joachim Backes
joachim.backes: review-
Details

  None (edit)
Description Joachim Backes 2013-06-20 06:21:42 EDT
Description of problem:

I think this is a problem of the LO version 4.1:

In earlier versions, the usage of the gallery was very simple: I had to drag an objects into the document, and that was it.

In LO version 4.1, for the most gallery objetcs this method fails: I can drag an gallery object over some page of the LO document, and a small "+" icon appears, but if I release the mouse pointer, the gallery object does not appear in the document. This happens for the most of gallery objects. Only for a few objects, the old drag/drop method is able, but I cannot realize any algorithm.

The only method I can use is to use the add->copy context menu with the right mouse button. This will position the object in the center of the documents page.

Additionally, it is not possible to edit such an inserted object (removing the shadow, change the line/border width or change/remove the background color, remove the shadow a.s.o).

Version-Release number of selected component (if applicable):
libreoffice-core-4.1.0.0-9.beta2.fc19.x86_64,...

How reproducible:
For the most gallery objects

Steps to Reproduce:
1.try to drag an gallery object into some document page
2.
3.

Actual results:
nothing happens

Expected results:
the objects appears on the document's page and is editable!

Additional info:
Comment 1 Joachim Backes 2013-06-20 09:01:58 EDT
Created attachment 763454 [details]
Screencasting what i did
Comment 2 Caolan McNamara 2013-06-20 12:20:52 EDT
Hmph!, where do all those galleries come from, you've way more than the default set (the one that did work is from the default set). Have you some gallery extension installed or some personal galleries created ? Looks like we mishandling those for some reason or other so I'd need to get my hands on those.
Comment 3 Joachim Backes 2013-06-20 14:01:08 EDT
Created attachment 763556 [details]
All the extensions I installed

The gallery objects *all* result from extensions I installed, and they are all are working since years -in OpenOffice and in *all* previous LibreOffice versions-. I have attached the list of installed extensions.
Comment 4 Joachim Backes 2013-06-21 04:09:27 EDT
I could get rid of the described problems by removing
~/.config/libreoffice/4/user/uno_packages/cache. But after this the gallery only had the std LO objects. But: I could insert the std objects by drag/drop.

You can try to load my old extensions by opening

https://www-user.rhrk.uni-kl.de/~backes/DL/Libreoffice-Extensions.tgz

Please inform me if you have read this file so I can remove it.

I guess these old style extensions containg my old gallery objects are incompatible with LO 4. Is there a conversion tool?
Comment 5 Caolan McNamara 2013-06-23 15:44:02 EDT
nah, this is a bog-standard bug. It should work, found the regression now.
Comment 6 Joachim Backes 2013-06-24 00:35:03 EDT
Hurra, it runs with libreoffice-4.1.0.1-3.fc19. 

Bug can be closed.

Thank you.

JB
Comment 7 Fedora Update System 2013-06-24 04:17:15 EDT
libreoffice-4.1.0.1-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libreoffice-4.1.0.1-3.fc19
Comment 8 Fedora Update System 2013-06-24 14:49:38 EDT
Package libreoffice-4.1.0.1-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-4.1.0.1-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11601/libreoffice-4.1.0.1-3.fc19
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2013-06-29 14:18:02 EDT
libreoffice-4.1.0.1-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.