Bug 976310
| Summary: | [virtio-win][compatibilty]Guest freeze After terminating the virtserialport receiving side in the host | ||
|---|---|---|---|
| Product: | Red Hat Enterprise Linux 6 | Reporter: | Jan Kurik <jkurik> |
| Component: | virtio-win | Assignee: | Vadim Rozenfeld <vrozenfe> |
| Status: | CLOSED ERRATA | QA Contact: | Virtualization Bugs <virt-bugs> |
| Severity: | urgent | Docs Contact: | |
| Priority: | urgent | ||
| Version: | 6.3 | CC: | abienven, acathrow, ahoness, areis, asegundo, bcao, bsarathy, byount, colin.coe, ghammer, jintli, juzhang, jwest, lijin, lmiksik, lveyde, mdeng, michen, mkenneth, mkrcmari, pdemmers, pm-eus, qzhang, rhod, syeghiay, tdosek, virt-maint, vrozenfe, yanzhao, yqu, yvugenfi |
| Target Milestone: | rc | Keywords: | ZStream |
| Target Release: | --- | ||
| Hardware: | Unspecified | ||
| OS: | Unspecified | ||
| Whiteboard: | |||
| Fixed In Version: | Doc Type: | Bug Fix | |
| Doc Text: |
Previously, a guest became unresponsive after the virtqueue was full. This caused a bug check to occur, and the netkvm driver wrote to the read-only Interrupt Service Routine (ISR) register. The write caused QEMU to respond with a "virtio_ioport_write: unexpected address 0x13 value 0x0" error message. This update corrects this issue on the dst-host after termination of the listening side of a virtserialport host, and interruptions and error messages no longer occur in the described scenario.
|
Story Points: | --- |
| Clone Of: | Environment: | ||
| Last Closed: | 2013-07-04 14:08:32 UTC | Type: | --- |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
| Bug Depends On: | 823818 | ||
| Bug Blocks: | |||
|
Description
Jan Kurik
2013-06-20 10:58:08 UTC
Reproduced this issue on virtio-win-prewhql-49
Verified this issue on virtio-win-1.6.5-4.el6_4
steps;
1.boot a guest with virtio-serial-pci:
/usr/libexec/qemu-kvm -M rhel6.4.0 -m 6G -smp 4 -cpu cpu64-rhel6,+x2apic -usb -device usb-tablet -drive file=win2k8-64-816-actived.raw,format=raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -netdev tap,id=hostnet0,script=/etc/qemu-ifup -device rtl8139,netdev=hostnet0,mac=00:52:4f:15:34:06,id=net0 -uuid bc70cb3f-e54c-497e-974b-14b5c8f7a3f5 -rtc-td-hack -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win2k8-64-serial,server,nowait -mon chardev=111a,mode=readline -name win2k8-64-serial -vnc :1 -vga cirrus -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -device virtio-serial-pci,id=virtio-serial0,max_ports=16 -chardev socket,path=/tmp/tt0,server,nowait,id=channel0 -device virtserialport,chardev=channel0,name=com.redhat.rhevm.vdsm,bus=virtio-serial0.0,id=port0 -cdrom /usr/share/virtio-win/virtio-win-1.6.5.iso
2.Stop RHEV-Agent Service in the guest(if there is RHEV-Agent Service)
3.transfer data from guest to with no listening side:
in guest: transfer file:
> type 1.bat
:start
copy 1.log \\.\Global\.\com.redhat.rhevm.vdsm
goto start
Actual Results:
on virtio-win-prewhql-49 , guest freeze after a while guest sending data.
on virtio-win-1.6.5-4.el6_4,guest works normally,data can be transferred successfully.
Based on above ,this issue has been fixed already .
Move status to VERIFIED according to comment #5 Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory, and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. http://rhn.redhat.com/errata/RHBA-2013-1016.html *** Bug 964070 has been marked as a duplicate of this bug. *** |