Bug 976310 - [virtio-win][compatibilty]Guest freeze After terminating the virtserialport receiving side in the host
[virtio-win][compatibilty]Guest freeze After terminating the virtserialport r...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.3
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
: ZStream
: 964070 (view as bug list)
Depends On: 823818
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-20 06:58 EDT by Jan Kurik
Modified: 2013-10-21 12:23 EDT (History)
31 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, a guest became unresponsive after the virtqueue was full. This caused a bug check to occur, and the netkvm driver wrote to the read-only Interrupt Service Routine (ISR) register. The write caused QEMU to respond with a "virtio_ioport_write: unexpected address 0x13 value 0x0" error message. This update corrects this issue on the dst-host after termination of the listening side of a virtserialport host, and interruptions and error messages no longer occur in the described scenario.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-04 10:08:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 344933 None None None Never

  None (edit)
Description Jan Kurik 2013-06-20 06:58:08 EDT
This bug has been copied from bug #823818 and has been proposed
to be backported to 6.4 z-stream (EUS).
Comment 5 lijin 2013-06-28 06:13:04 EDT
Reproduced this issue on virtio-win-prewhql-49 
Verified this issue on virtio-win-1.6.5-4.el6_4

steps;
1.boot a guest  with virtio-serial-pci:
/usr/libexec/qemu-kvm -M rhel6.4.0 -m 6G -smp 4 -cpu cpu64-rhel6,+x2apic -usb -device usb-tablet -drive file=win2k8-64-816-actived.raw,format=raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -netdev tap,id=hostnet0,script=/etc/qemu-ifup -device rtl8139,netdev=hostnet0,mac=00:52:4f:15:34:06,id=net0 -uuid bc70cb3f-e54c-497e-974b-14b5c8f7a3f5 -rtc-td-hack -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win2k8-64-serial,server,nowait -mon chardev=111a,mode=readline -name win2k8-64-serial -vnc :1 -vga cirrus -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -device virtio-serial-pci,id=virtio-serial0,max_ports=16 -chardev socket,path=/tmp/tt0,server,nowait,id=channel0 -device virtserialport,chardev=channel0,name=com.redhat.rhevm.vdsm,bus=virtio-serial0.0,id=port0 -cdrom /usr/share/virtio-win/virtio-win-1.6.5.iso

2.Stop RHEV-Agent Service in the guest(if there is RHEV-Agent Service)

3.transfer data from guest to with no listening side:

   in guest: transfer file:

> type 1.bat

  :start

  copy 1.log \\.\Global\.\com.redhat.rhevm.vdsm

  goto start

Actual Results:
on virtio-win-prewhql-49 , guest freeze after a while guest sending data.
on virtio-win-1.6.5-4.el6_4,guest works normally,data can be transferred successfully.

Based on above ,this issue has been fixed already .
Comment 6 Mike Cao 2013-06-30 23:24:48 EDT
Move status to VERIFIED according to comment #5
Comment 8 errata-xmlrpc 2013-07-04 10:08:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1016.html
Comment 9 Mike Cao 2013-10-08 06:10:04 EDT
*** Bug 964070 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.