Bug 976346 - policycoreutils requires systemd-sysv, but it's not used
policycoreutils requires systemd-sysv, but it's not used
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-20 08:24 EDT by Harald Hoyer
Modified: 2013-06-29 14:02 EDT (History)
2 users (show)

See Also:
Fixed In Version: policycoreutils-2.1.14-46.4.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-29 14:02:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Hoyer 2013-06-20 08:24:40 EDT
I can't see the usage of /usr/bin/systemd-sysv-convert (systemd-sysv).

Why does the specfile have:

Requires(post): systemd-sysv

This requirement unnecessarily pulls in python in a bare minimal install, because of this.
Comment 1 Daniel Walsh 2013-06-21 07:59:29 EDT
I have no idea why that is there other then maybe when we were requested to change

%post restorecond
%systemd_post restorecond.service

%preun restorecond
%systemd_preun restorecond.service

%postun restorecond
%systemd_postun_with_restart restorecond.service

policycoreutils-2.1.14-46.3.fc19 removes the requirement.
Comment 2 Fedora Update System 2013-06-22 06:17:10 EDT
policycoreutils-2.1.14-46.4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/policycoreutils-2.1.14-46.4.fc19
Comment 3 Fedora Update System 2013-06-22 14:14:49 EDT
Package policycoreutils-2.1.14-46.4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing policycoreutils-2.1.14-46.4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11469/policycoreutils-2.1.14-46.4.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-06-29 14:02:50 EDT
policycoreutils-2.1.14-46.4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.