Bug 976365 - sync status UI shows incorrect size and incorrect package count upon successful re-syncing after "Error syncing"
sync status UI shows incorrect size and incorrect package count upon successf...
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Eric Helms
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-20 08:54 EDT by Kedar Bidarkar
Modified: 2014-06-19 14:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-03 10:45:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
incorrect_sync_info (42.97 KB, image/png)
2013-06-20 08:54 EDT, Kedar Bidarkar
no flags Details

  None (edit)
Description Kedar Bidarkar 2013-06-20 08:54:41 EDT
Created attachment 763453 [details]
incorrect_sync_info

Description of problem:

Tried re-syncing RHEL6 6Server repo after a failed sync .

IT now shows incorrect size and package count.

Looks like it's now showing only the size and package count of the rpms only downloaded after the re-sync.

Version-Release number of selected component (if applicable):
os]# rpm -qav | grep -i katello
katello-cli-1.4.2-7.el6sat.noarch
katello-glue-pulp-1.4.2-14.el6sat.noarch
katello-foreman-all-1.4.2-14.el6sat.noarch
katello-qpid-client-key-pair-1.0-1.noarch
ruby193-rubygem-katello_api-0.0.3-2.el6_4.noarch
katello-common-1.4.2-14.el6sat.noarch
katello-selinux-1.4.3-3.el6sat.noarch
katello-all-1.4.2-14.el6sat.noarch
katello-glue-elasticsearch-1.4.2-14.el6sat.noarch
katello-configure-1.4.3-16.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.3-5.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
ruby193-rubygem-foreman-katello-engine-0.0.8-6.el6sat.noarch
katello-glue-candlepin-1.4.2-14.el6sat.noarch
katello-configure-foreman-1.4.3-16.el6sat.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
signo-katello-0.0.18-1.el6sat.noarch
katello-cli-common-1.4.2-7.el6sat.noarch
katello-1.4.2-14.el6sat.noarch



os]# rpm -qav | grep -i pulp
python-pulp-rpm-common-2.1.2-0.3.beta.el6sat.noarch
katello-glue-pulp-1.4.2-14.el6sat.noarch
m2crypto-0.21.1.pulp-8.el6sat.x86_64
python-oauth2-1.5.170-3.pulp.el6sat.noarch
pulp-server-2.1.2-0.3.beta.el6sat.noarch
python-pulp-common-2.1.2-0.3.beta.el6sat.noarch
python-rhsm-1.8.0-1.pulp.el6sat.x86_64
mod_wsgi-3.4-1.pulp.el6sat.x86_64
pulp-rpm-plugins-2.1.2-0.3.beta.el6sat.noarch
python-isodate-0.5.0-1.pulp.el6sat.noarch
pulp-selinux-2.1.2-0.3.beta.el6sat.noarch


How reproducible:

Attempting to resync after a failed sync

Steps to Reproduce:
1.
2.
3.

Actual results:
shows incorrect size of the repo and incorrect package count

Expected results:
Should be dispalying the right information.

Additional info:

The sync did finish completely upon re-syncing with a "Sync complete" message
Comment 1 RHEL Product and Program Management 2013-06-20 09:06:12 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Eric Helms 2013-10-03 10:24:26 EDT
I believe this is the correct behavior for this mechanism. The sync status page is not intended to show you the current size and package counts for the repository. Instead, the sync status page is showing you the results of the latest sync for a given repository. Thus, if you sync a repository and it only syncs down 50 packages that total 50MB, then you should only see that information displayed. For detailed information about a repository, you should visit the repository details page.

Note You need to log in before you can comment on or make changes to this bug.