Bug 976415 - Missing usermode-gtk in dependencies
Missing usermode-gtk in dependencies
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: liveusb-creator (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F19Blocker/F19FinalBlocker
  Show dependency treegraph
 
Reported: 2013-06-20 10:08 EDT by Petr Schindler
Modified: 2016-09-19 22:45 EDT (History)
10 users (show)

See Also:
Fixed In Version: liveusb-creator-3.11.8-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-26 13:08:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Schindler 2013-06-20 10:08:55 EDT
Description of problem:
liveusb-creator doesn't have usermode-gtk in dependencies. So after installation it can't be run from menu. After clicking on menu icon it is trying to load, but then nothing happens.

When run from terminal it asks for password properly.

Version-Release number of selected component (if applicable):
liveusb-creator-3.11.8-2.fc19.noarch

How reproducible:
always

Steps to Reproduce:
1. On freshly installed Fedora 19 install liveusb-creator
2. Try to run it from desktop menu (GNOME)

Actual results:
Nothing happens. Is loading for a while, but then nothing

Expected results:
User should be asked for root password in graphic.

Additional info:
Comment 1 Fedora Blocker Bugs Application 2013-06-20 10:20:33 EDT
Proposed as a Blocker for 19-final by Fedora user pschindl using the blocker tracking app because:

 liveusb-creator is supposed to be GUI tool, so it should be able to be run from graphical menu.
Related criterion: "Release-blocking live and dedicated installer images must boot when written to optical media of an appropriate size (if applicable) and when written to a USB stick with any of the officially supported methods."
Comment 2 Adam Williamson 2013-06-20 12:24:58 EDT
Discussed at 2013-06-20 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-06-20/f19final-blocker-review-7.1.2013-06-20-15.01.log.txt . Rejected as a blocker: it doesn't really fit the criterion, which is about making sure live images work when written to USB, not fixing minor bugs in the tools for writing them to USB. We might consider applying it to the case of a 'recommended' tool being 100% broken, but this is much less than that.

liveusb-creator is not on any of the release media, so there is little practical point in blocking the release to fix a bug in it: shipping the fix as a 0-day update would seem perfectly sufficient.

(I suspect this bug has shown up as other tools migrated away from usermode-gtk and dropped their dependencies on it; probably in older Fedoras it tended to be installed for something else anyway. On other desktops it likely still works - or started working again with TC5 - as they have the 'admin-tools' group).
Comment 3 Adam Williamson 2013-06-26 05:12:45 EDT
"liveusb-creator is not on any of the release media"

Well, actually, it is. It's on the KDE live install. D'oh.

Re-proposing as a blocker:

"All applications listed under the Applications menu or category must withstand a basic functionality test and not crash after a few minutes of normal use."

This bug causes it not to start from the KDE menus on the KDE live until you manually install consolehelper-gtk.
Comment 4 Adam Williamson 2013-06-26 05:13:11 EDT
Have to note, I don't understand why system-config-* all work fine without it.
Comment 5 Fedora Update System 2013-06-26 05:26:55 EDT
liveusb-creator-3.11.8-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/liveusb-creator-3.11.8-3.fc19
Comment 6 Adam Williamson 2013-06-26 05:41:17 EDT
Note, this package is only on the KDE live spin. If we take it as a blocker we do not really need to rebuild all of RC2, only the KDE live. I have verified it is not on the DVD.
Comment 7 Jaroslav Reznik 2013-06-26 06:36:42 EDT
I'd say workaround is pretty simple and it affects only KDE live spin and tool that's probably not used too much. For system configs - which one have you tried? Many of these are already using Polkit - that's the reason why it works.
Comment 8 Adam Williamson 2013-06-26 10:13:47 EDT
Whichever ones are on the live image.

I'd really quite like to fix this: I like the 'all apps on menus must launch' criterion, it's quite an important 'does this even look like it could pretend to be a real operating system' smell test. And we can fix it with pretty minimal impact.
Comment 9 Adam Williamson 2013-06-26 10:47:19 EDT
I don't see how the workaround is 'simple' either. How is it simple to go from 'bouncing icon and no app' to 'oh, I have to install the package usermode-gtk!'?
Comment 10 Adam Williamson 2013-06-26 12:27:02 EDT
Discussed at 2013-06-26 blocker review meeting. Accepted as a blocker per criterion "All applications listed under the Applications menu or category must start successfully".
Comment 11 Fedora Update System 2013-06-26 13:08:40 EDT
liveusb-creator-3.11.8-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.