Bug 976417 - Anaconda cannot reuse existing btrfs rootfs subvolume
Anaconda cannot reuse existing btrfs rootfs subvolume
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-20 10:12 EDT by Martin
Modified: 2014-09-14 20:04 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-20 10:37:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
warning when trying to reuse existing subvolume (1.05 MB, image/jpeg)
2013-06-20 12:59 EDT, Martin
no flags Details
information after removing and adding new subvolume (1.43 MB, image/jpeg)
2013-06-20 12:59 EDT, Martin
no flags Details
summary of changes (1.45 MB, image/jpeg)
2013-06-20 13:04 EDT, Martin
no flags Details

  None (edit)
Description Martin 2013-06-20 10:12:04 EDT
Description of problem:
Anaconda cannot reuse existing btrfs rootfs subvolume

Version-Release number of selected component (if applicable):
anaconda-19.30.9-1.fc19

How reproducible:
always

Steps to Reproduce:
1. Select Btrfs scheme and go to custom partitioning mode.
2. Find existing btrfs subvolume, eg. root00
3. Try to set root00 as "/" mountpoint for new installation.

Actual results:
Anaconda doesn't allow to use root00 as "/". Can't check "format" option.

Expected results:
I can set existing root00 as "/" and reformat it.

Additional info:
Workaround: I can remove root00 subvolume in Anaconda and then add new subvolume with root00 name as "/".
Comment 1 David Lehman 2013-06-20 10:37:32 EDT
This is working as designed. You cannot reformat a btrfs subvolume. There is no such operation. The closest you can come is to create a new subvolume for root. It does not matter if you remove the old one or not except in terms of disk space. Note that you cannot reuse an existing filesystem of any type for the root filesystem during OS installation -- it is not specific to btrfs.
Comment 2 Martin 2013-06-20 11:53:24 EDT
Sounds consistent with what I know about Btrfs subvolume.

My proposal is, could Anaconda abstract this from user and instead of having user to manually remove subvolume and create new with same name "root00" (which is currently possible), Anaconda could just do this for user automatically when user selects existing rootfs for new installation? And then warn user, that existing subvolume will be removed and new with same name will be created instead.
Comment 3 David Lehman 2013-06-20 12:18:29 EDT
The problem is that to do that you would have to warn the user in a fairly loud/intrusive way. The frequent appearance of pop-up dialogs containing warnings or other information is something we have decided to avoid, and you would be surprised to hear how many of them have been proposed since we redesigned the user interface. If we added a fraction of them you would be nearly constantly reading and clicking through informational pop-up dialogs.
Comment 4 Martin 2013-06-20 12:59:08 EDT
Created attachment 763529 [details]
warning when trying to reuse existing subvolume
Comment 5 Martin 2013-06-20 12:59:56 EDT
Created attachment 763530 [details]
information after removing and adding new subvolume
Comment 6 Martin 2013-06-20 13:04:20 EDT
Created attachment 763531 [details]
summary of changes

Ok forget about the popup dialog and look at current solution.

variant A: User can be notified about removing and recreating "root00" subvolume and therefore losing all data on it. Same way as on "warning when trying to reuse existing subvolume" screenshot.

variant B: User can be warned in "Summary of changes" same way as now. So no change needed here.
Comment 7 David Lehman 2013-06-20 13:11:33 EDT
Neither of the examples you cite is conveying information about a destructive operation, ie: it is not completely critical that the user sees the information.
Comment 8 Martin 2013-06-20 13:16:14 EDT
And what is in "summary of changes"?

Note You need to log in before you can comment on or make changes to this bug.