Bug 976449 - [RFE] Filter scheduler for cell scheduling
Summary: [RFE] Filter scheduler for cell scheduling
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova   
(Show other bugs)
Version: 4.0
Hardware: Unspecified Unspecified
high
high
Target Milestone: Upstream M1
: 4.0
Assignee: Xavier Queralt
QA Contact: Nikola Dipanov
URL: https://blueprints.launchpad.net/nova...
Whiteboard:
Keywords: FutureFeature, OtherQA, TestOnly
Depends On: 988959
Blocks: RHOS40RFE 1045051
TreeView+ depends on / blocked
 
Reported: 2013-06-20 15:18 UTC by Russell Bryant
Modified: 2016-04-26 17:33 UTC (History)
8 users (show)

Fixed In Version: openstack-nova-2013.2-0.8.b2.el6ost
Doc Type: Enhancement
Doc Text:
Instances can now be created in preferred cells. Previously, the cell scheduler would select a destination at random from known cells. Filters and weights can now be defined by administrators to direct builds to a particular cell. The keys scheduler_filter_classes and scheduler_filter_classes are configured under the cells group in nova.conf. The new weights and filters available: ram_by_instance_type: Select cells with the most capacity for the instance type being requested. weight_offset: Modifies the DB to weight a particular cell. Also useful for disabling a cell. mute_child: Assigns negative weight to cells that have not sent an update to their parent cell. target_cell: Specifies a scheduler.
Story Points: ---
Clone Of:
: 1045051 (view as bug list)
Environment:
Last Closed: 2013-12-20 00:07:20 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2013:1859 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2013-12-21 00:01:48 UTC
OpenStack gerrit 16221 None None None Never
OpenStack gerrit 29949 None None None Never

Description Russell Bryant 2013-06-20 15:18:43 UTC
Havana includes a filter scheduler for cells.

https://blueprints.launchpad.net/nova/+spec/cells-filter-scheduler

Testing details depend on what filters end up in Nova by the time Havana is released.

Comment 7 Ami Jeain 2013-10-28 11:35:43 UTC
QANAK'ing due to QE capacity

Comment 14 errata-xmlrpc 2013-12-20 00:07:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html


Note You need to log in before you can comment on or make changes to this bug.