Bug 976452 - [RFE] v3 compute API
[RFE] v3 compute API
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
unspecified
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Russell Bryant
Ami Jeain
https://blueprints.launchpad.net/nova...
upstream_milestone_next upstream_stat...
: FutureFeature, TechPreview, Triaged
: 894823 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-20 11:23 EDT by Russell Bryant
Modified: 2016-04-26 14:52 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Technology Preview
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-15 11:48:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Bryant 2013-06-20 11:23:28 EDT
Havana will include a new rev of the compute API.  There are a lot of blueprints and a ton of patches that make up this effort.  The top level blueprint is here:

https://blueprints.launchpad.net/nova/+spec/nova-v3-api
Comment 1 Russell Bryant 2013-07-23 15:11:44 EDT
This isn't going to be done for Havana.  The API will be present but unfinished and experimental, so this needs to be bumped to RHOS 5.0.
Comment 2 Russell Bryant 2013-07-23 15:12:08 EDT
*** Bug 894823 has been marked as a duplicate of this bug. ***
Comment 4 Stephen Gordon 2014-01-24 11:32:06 EST
Updating based on BP milesone.

Note You need to log in before you can comment on or make changes to this bug.