Bug 97647 - Files uploaded with php double in size (approx) and end up corrupt.
Summary: Files uploaded with php double in size (approx) and end up corrupt.
Status: CLOSED DUPLICATE of bug 82967
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: php   
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-18 19:49 UTC by Derek Kenny
Modified: 2007-04-18 16:54 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:56:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My apache config. (24.81 KB, text/plain)
2003-06-19 04:21 UTC, Derek Kenny
no flags Details
My php config. (460 bytes, text/plain)
2003-06-19 04:24 UTC, Derek Kenny
no flags Details

Description Derek Kenny 2003-06-18 19:49:05 UTC
Description of problem: I moved my old php application to redhat v9 and my 
uploaded files were getting corrupted. The file size of the uploaded document 
was approximately 2X that of the original. To work around this problem I built 
php from source and now uploaded files are once again ok.


Version-Release number of selected component (if applicable):
php-4.2.2-17

How reproducible:
Should be easy.

Steps to Reproduce:
1. Install Redhat9 with php, mysql and apache.
2. Install a php script that handles file uploads into Apache's doc root.
3. Upload a file and try opening it. Also, compare the size to the original.
    
Actual results:
File cannot be opened and the uploaded file is 2X as large as the original.


Expected results:


Additional info:

Comment 1 Joe Orton 2003-06-18 20:10:43 UTC
Can you attach your /etc/httpd/conf/httpd.conf  and /etc/httpd/conf.d/php.conf
files? This can happen because of a configuration error.

Comment 2 Derek Kenny 2003-06-19 04:21:24 UTC
Created attachment 92476 [details]
My apache config.

Comment 3 Derek Kenny 2003-06-19 04:24:29 UTC
Created attachment 92477 [details]
My php config.

Comment 4 Joe Orton 2003-06-19 08:00:16 UTC
Thanks.  You've added the line:

  AddType application/x-httpd-php .php

to httpd.conf - this is known to cause problems with the symptoms you describe.
 Can you remove this and try your scripts again?

Comment 5 Derek Kenny 2003-06-19 14:53:38 UTC
Without that line in the httpd.conf, the script does not seem to run properly 
and I end up with most of the code echoed to the screen. The install notes for 
php indicate that the line needs to be there. Also, the version I built from 
source works fine with that line in the httpd.conf.
Please let me know if I missed something or misunderstood the request.

Comment 6 Joe Orton 2003-06-21 09:36:59 UTC
That shouldn't happen.  You've also added the line:

LoadModule php4_module modules/libphp4.so

to your httpd.conf - if PHP does not work without that line, then your

/etc/httpd/conf.d/php.conf 

file is not getting loaded.

Comment 7 Joe Orton 2003-07-03 11:51:37 UTC
This is likely a duplicate of bug 82967, for which an erratum was just issued.

*** This bug has been marked as a duplicate of 82967 ***

Comment 8 Red Hat Bugzilla 2006-02-21 18:56:46 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.