Bug 97648 - vim won't start, can't find libtinfo.so.5
vim won't start, can't find libtinfo.so.5
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: vim (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-18 15:52 EDT by Ben Greear
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-18 18:48:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Greear 2003-06-18 15:52:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030529

Description of problem:
I upgraded my system from 7.3 to RH 9, now vim will not work:

[root@grok RPMS]# vim
vim: error while loading shared libraries: libtinfo.so.5: cannot open shared
object file: No such file or directory


[root@grok RPMS]# ldd /usr/bin/vim
        libncurses.so.5 => /usr/lib/libncurses.so.5 (0x40032000)
        libacl.so.1 => /lib/libacl.so.1 (0x40071000)
        libgpm.so.1 => /usr/lib/libgpm.so.1 (0x40077000)
        libdl.so.2 => /lib/libdl.so.2 (0x4007e000)
        libperl.so =>
/usr/lib/perl5/5.8.0/i386-linux-thread-multi/CORE/libperl.so (0x40082000)
        libutil.so.1 => /lib/libutil.so.1 (0x401aa000)
        libm.so.6 => /lib/i686/libm.so.6 (0x401ad000)
        libc.so.6 => /lib/i686/libc.so.6 (0x401cf000)
        libpthread.so.0 => /lib/i686/libpthread.so.0 (0x40307000)
        libattr.so.1 => /lib/libattr.so.1 (0x40358000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
        libtinfo.so.5 => not found
        libnsl.so.1 => /lib/libnsl.so.1 (0x4035b000)
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x40370000)
[root@grok RPMS]#


I can't seem to find any RPM that provides libtinfo, and wherever
it exists, it should be a pre-req for the VIM rpm...


Version-Release number of selected component (if applicable):
vim-common-6.1-29

How reproducible:
Didn't try

Steps to Reproduce:
1. Ran 7.3, keep it up to date, mostly
2. Upgraded to RH 9
3. libtinfo.so.5 was removed from my system and vim won't work.
    

Additional info:
Comment 1 Karsten Hopp 2003-06-18 16:32:24 EDT
I checked the vim binaries from 7.3, the 7.3 errata version and the one from Red Hat Linux 9. 
None of them requires a libtinfo.so.5. 
Please add the output of the following commands to this bugreport: 
rpm -qa | grep vim 
rpm -qif /usr/bin/vim 
rpm -Vf /usr/bin/vim 
Comment 2 Ben Greear 2003-06-18 17:09:34 EDT
[root@grok RPMS]# rpm -qa|grep vim
vim-minimal-6.1-29
vim-common-6.1-29
vim-enhanced-6.1-29

[root@grok RPMS]# rpm -qif /usr/bin/vim
Name        : vim-enhanced                 Relocations: (not relocateable)
Version     : 6.1                               Vendor: Red Hat, Inc.
Release     : 29                            Build Date: Wed 12 Feb 2003 04:44:44
AM PST
Install Date: Wed 18 Jun 2003 12:48:08 PM PDT      Build Host:
stripples.devel.redhat.com
Group       : Applications/Editors          Source RPM: vim-6.1-29.src.rpm
Size        : 1896376                          License: freeware
Signature   : DSA/SHA1, Sun 23 Feb 2003 10:05:37 PM PST, Key ID 219180cddb42a60e
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Summary     : A version of the VIM editor which includes recent enhancements.
Description :
VIM (Vi IMproved) is an updated and improved version of the vi editor.
Vi was the first real screen-based editor for UNIX, and is still very
popular. VIM improves on vi by adding new features: multiple windows,
multi-level undo, block highlighting, and more. The vim-enhanced
package contains a version of VIM with extra, recently introduced
features like Python and Perl interpreters.
 
Install the vim-enhanced package if you want to use a version of the
VIM editor which includes recently added enhancements like
interpreters for the Python and Perl scripting languages. You will
also need to install the vim-common package.
[root@grok RPMS]#

[root@grok RPMS]# rpm -Vf /usr/bin/vim
[root@grok RPMS]#


Comment 3 Ben Greear 2003-06-18 17:15:06 EDT
Also, I explicitly removed all the vim RPMs and re-installed them from
the RH9 CDROM RPMs.  I verified that the /usr/bin/vim executable went
away when I removed everything...and it was back after installing the
RPMS..so I don't think it was some crufty vim that somehow crawled onto
my system...

Just in case:

[root@grok RPMS]# md5sum /usr/bin/vim
070fd8b623b374de74e445131245c978  /usr/bin/vim
Comment 4 Karsten Hopp 2003-06-18 18:48:50 EDT
It looks like you have installed a package which isn't from Red Hat and this breaks vim and 
probably quite a few more packages. 
One suspect would be ncurses, if you compile that one with some special options, you'll get 
libncurses and libtinfo.  
Try rpm -q --whatrequires libtinfo.so.5  to see which package needs this library. 
Comment 5 Ben Greear 2003-06-18 19:02:06 EDT
[root@grok RPMS]# rpm -q --whatrequires libtinfo.so.5
gpm-libs-1.20.0-0.9
[root@grok RPMS]#

Does this imply that gpm-libs is the thing that is screwing me up?

How do I go about fixing this?

Note You need to log in before you can comment on or make changes to this bug.