Bug 976529 - e-mail compose hang
e-mail compose hang
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-20 14:16 EDT by Eric Paris
Modified: 2013-07-22 21:16 EDT (History)
4 users (show)

See Also:
Fixed In Version: libsoup-2.42.2-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-22 21:16:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
thread apply all bt of evolution-address-factory (11.56 KB, text/plain)
2013-06-20 14:16 EDT, Eric Paris
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 698912 None None None Never

  None (edit)
Description Eric Paris 2013-06-20 14:16:20 EDT
Created attachment 763558 [details]
thread apply all bt    of evolution-address-factory

evolution-3.8.3-1.fc19.x86_64

I semi-regularly get a hang when I try to compose a new mail message.  I just get a solid grey screen.  I can click the X in the top right and eventually can 'force quit'.  (or I can do what I normally do and pkill -9 evolution)

The last couple of times I hit this problem I had one compose window open and clicked to compose a second e-mail.  The second compose window was what actually hung.

Attached you will a copy of 'thread apply all backtrace' after I attached gdb to the evolution-address-factory process while the grey screen hang was happening.
Comment 1 Matthew Barnes 2013-06-21 00:06:33 EDT
Looks like https://bugzilla.gnome.org/show_bug.cgi?id=698912.
Comment 2 Milan Crha 2013-06-21 04:58:21 EDT
Thanks for a bug report. Could you get backtrace of evolution itself, please? As long as evolution is frozen, then its backtrace matters. From that we can move to other processes to see what they do (like for the addressbook factory, as you already did), but for the starter the frozen process is the place where to begin.

If Matthew's bug will be the right one, then I'll upstream this there. If not, I'll upstream it in a new bug report. It's because it doesn't seem to be Fedora issue, but a general evolution issue, for which the Gnome bugzilla is the place where to report issues.
Comment 3 Fedora Update System 2013-07-12 17:05:15 EDT
libsoup-2.42.2-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libsoup-2.42.2-2.fc19
Comment 4 Fedora Update System 2013-07-13 23:40:08 EDT
Package libsoup-2.42.2-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libsoup-2.42.2-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12976/libsoup-2.42.2-2.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-07-22 21:16:48 EDT
libsoup-2.42.2-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.