Bug 976541 - libvirt-0.10.2-18.el6_4.8.x86_64 breaks both VNC and SPICE console access
libvirt-0.10.2-18.el6_4.8.x86_64 breaks both VNC and SPICE console access
Status: CLOSED DUPLICATE of bug 976401
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.2.0
Unspecified Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-20 14:31 EDT by Jason Montleon
Modified: 2013-06-20 17:17 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-20 17:17:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Montleon 2013-06-20 14:31:46 EDT
Description of problem:
libvirt-0.10.2-18.el6_4.8.x86_64 breaks both VNC and SPICE console access in RHEV 3.2

Version-Release number of selected component (if applicable):
libvirt-client-0.10.2-18.el6_4.8.x86_64
libvirt-0.10.2-18.el6_4.8.x86_64
libvirt-lock-sanlock-0.10.2-18.el6_4.8.x86_64
libvirt-python-0.10.2-18.el6_4.8.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install RHEV 3.2
2. Upgrade libvirt to 0.10.2-18.el6_4.8.x86_64
3. Restart hypervisors, possibly also management server.

Actual results:
In the webadmin interface I get the error message, "Error while executing action SetVmTicket: Unexpected exception".

Expected results:
Console opens up

Additional info:
Shutting down the VM's, putting the hypervisor into maintenance, running 'yum downgrade libvirt*' to get 0.10.2-18.el6_4.5, setting the host back to active, and restarting the vm's gets things working normally again.

I had to do downgrade the packages and restart ovirt-engine on the management server to get SPICE working again. VNC worked again just from doing the above steps on the hypervisor.

################################
vdsm log from hypervisor host:
################################
Thread-218::DEBUG::2013-06-20 14:13:22,964::BindingXMLRPC::913::vds::(wrapper) client [192.168.122.2]::call vmSetTicket with ('0549b463-5070-4a60-9120-398ecbbc9c00', '5nicWjphLVDV', '120', 'disconnect', {'userName': 'admin@internal', 'userId': 'fdfc627c-d875-11e0-90f0-83df133b58cc'}) {} flowID [7140ba3d]
Thread-218::DEBUG::2013-06-20 14:13:22,981::libvirtconnection::128::vds::(wrapper) Unknown libvirterror: ecode: 1 edom: 10 level: 2 message: internal error cannot change listen address setting on vnc graphics
Thread-218::ERROR::2013-06-20 14:13:22,981::BindingXMLRPC::923::vds::(wrapper) libvirt error
Traceback (most recent call last):
  File "/usr/share/vdsm/BindingXMLRPC.py", line 918, in wrapper
    res = f(*args, **kwargs)
  File "/usr/share/vdsm/BindingXMLRPC.py", line 223, in vmSetTicket
    return vm.setTicket(password, ttl, existingConnAction, params)
  File "/usr/share/vdsm/API.py", line 571, in setTicket
    return v.setTicket(password, ttl, existingConnAction, params)
  File "/usr/share/vdsm/libvirtvm.py", line 2488, in setTicket
    self._dom.updateDeviceFlags(graphics.toxml(), 0)
  File "/usr/share/vdsm/libvirtvm.py", line 531, in f
    ret = attr(*args, **kwargs)
  File "/usr/lib64/python2.6/site-packages/vdsm/libvirtconnection.py", line 104, in wrapper
    ret = f(*args, **kwargs)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 1742, in updateDeviceFlags
    if ret == -1: raise libvirtError ('virDomainUpdateDeviceFlags() failed', dom=self)
libvirtError: internal error cannot change listen address setting on vnc graphics

################################
engine log from management host:
################################
AuditLogDirector] (QuartzScheduler_Worker-4) No string for UNASSIGNED type. Use default Log
2013-06-20 14:13:23,219 INFO  [org.ovirt.engine.core.bll.SetVmTicketCommand] (ajp-/127.0.0.1:8702-4) [7140ba3d] Running command: SetVmTicketCommand internal: false. Entities affected :  ID: 0549b463-5070-4a60-9120-398ecbbc9c00 Type: VM
2013-06-20 14:13:23,223 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.SetVmTicketVDSCommand] (ajp-/127.0.0.1:8702-4) [7140ba3d] START, SetVmTicketVDSCommand(HostName = s03.montleon.priv, HostId = af3640dc-aea6-11e2-813a-000000000002, vmId=0549b463-5070-4a60-9120-398ecbbc9c00, ticket=5nicWjphLVDV, validTime=120,m userName=admin@internal, userId=fdfc627c-d875-11e0-90f0-83df133b58cc), log id: 6e76f4a
2013-06-20 14:13:23,258 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.BrokerCommandBase] (ajp-/127.0.0.1:8702-4) [7140ba3d] Failed in SetVmTicketVDS method
2013-06-20 14:13:23,258 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.BrokerCommandBase] (ajp-/127.0.0.1:8702-4) [7140ba3d] Error code unexpected and error message VDSGenericException: VDSErrorException: Failed to SetVmTicketVDS, error = Unexpected exception
2013-06-20 14:13:23,258 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.BrokerCommandBase] (ajp-/127.0.0.1:8702-4) [7140ba3d] Command org.ovirt.engine.core.vdsbroker.vdsbroker.SetVmTicketVDSCommand return value 
 StatusOnlyReturnForXmlRpc [mStatus=StatusForXmlRpc [mCode=16, mMessage=Unexpected exception]]
2013-06-20 14:13:23,258 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.BrokerCommandBase] (ajp-/127.0.0.1:8702-4) [7140ba3d] HostName = s03.montleon.priv
2013-06-20 14:13:23,258 ERROR [org.ovirt.engine.core.vdsbroker.VDSCommandBase] (ajp-/127.0.0.1:8702-4) [7140ba3d] Command SetVmTicketVDS execution failed. Exception: VDSErrorException: VDSGenericException: VDSErrorException: Failed to SetVmTicketVDS, error = Unexpected exception
2013-06-20 14:13:23,258 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.SetVmTicketVDSCommand] (ajp-/127.0.0.1:8702-4) [7140ba3d] FINISH, SetVmTicketVDSCommand, log id: 6e76f4a
2013-06-20 14:13:23,258 ERROR [org.ovirt.engine.core.bll.SetVmTicketCommand] (ajp-/127.0.0.1:8702-4) [7140ba3d] Command org.ovirt.engine.core.bll.SetVmTicketCommand throw Vdc Bll exception. With error message VdcBLLException: org.ovirt.engine.core.vdsbroker.vdsbroker.VDSErrorException: VDSGenericException: VDSErrorException: Failed to SetVmTicketVDS, error = Unexpected exception
2013-06-20 14:13:23,260 ERROR [org.ovirt.engine.core.bll.SetVmTicketCommand] (ajp-/127.0.0.1:8702-4) [7140ba3d] Transaction rolled-back for command: org.ovirt.engine.core.bll.SetVmTicketCommand.
Comment 1 Jason Montleon 2013-06-20 17:09:25 EDT
This might be a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=976401

Looks very similar.
Comment 2 Jason Montleon 2013-06-20 17:17:04 EDT

*** This bug has been marked as a duplicate of bug 976401 ***

Note You need to log in before you can comment on or make changes to this bug.