This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 976604 - The "Browse by tag" button does not work on the create application page in development mode.
The "Browse by tag" button does not work on the create application page in de...
Status: CLOSED WONTFIX
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On: 976202 1123830
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-20 22:00 EDT by Jason DeTiberus
Modified: 2015-05-14 21:23 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 976202
Environment:
Last Closed: 2014-07-11 14:23:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason DeTiberus 2013-06-20 22:00:40 EDT
+++ This bug was initially created as a clone of Bug #976202 +++

Description of problem:

Tested on development mode, clicked the "Browse by tag" button on the create application page, found that it does not work when clicking ,the dropdown menu will not be displayed.

Version-Release number of selected component (if applicable):
OpenShiftEnterprise 1.2 RC1

How reproducible:
always

Steps to Reproduce:
1.Go to create application page
2.Click the "Browse by tag" button
3.

Actual results:

The "Browse by tag" button does not work.

Expected results:

The "Browse by tag" button should work correctly.

Additional info:

This looks to be an issue with Rails 3.1+ where with asset debugging turned on assets are included twice (once in the individual files and once in the cached compiled files) when in development mode.
Comment 1 Yujie Zhang 2013-06-21 06:44:57 EDT
This issue only exists on enterprise, does not exist on online.
Comment 2 Brenton Leanhardt 2013-06-21 10:37:50 EDT
We're actually curious about Origin.  We're fairly certain Origin has the bug.
Comment 3 Jason DeTiberus 2013-06-21 14:40:39 EDT
I just verified this bug in the latest origin rhel devenv (the fedora devenv does not exhibit the same behavior)
Comment 4 Jordan Liggitt 2013-10-25 09:38:17 EDT
The button is working correctly in origin for me. Are you saying it happens in RHEL but not in Fedora?
Comment 5 Jordan Liggitt 2014-07-11 14:23:45 EDT
Seems to be an issue with Rails when running in development mode with compiled assets available. In normal practice, we don't have precompiled assets available when in development mode.

To clear precompiled assets:
Run RAILS_ENV=development rake assets:clean to clear out tmp/assets

Note You need to log in before you can comment on or make changes to this bug.