Bug 976605 - Ability to manually recover VMs from "Unknown" state
Ability to manually recover VMs from "Unknown" state
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
3.3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Cathrow
virt
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-20 22:04 EDT by Marina
Modified: 2014-09-07 18:55 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-24 05:14:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 40685 None None None Never

  None (edit)
Description Marina 2013-06-20 22:04:19 EDT
2. Who is the customer behind the request?
GSS.

3. What is the nature and description of the request?
Create a utility/UI option to recover VMs from "Unknown" state.

4. Why does the customer need this? (List the business requirements here)
Very frequently, on customers setups VMs get into Unknown state without any ability on the Admin Portal to recover. This requires opening support ticket and implementing manual fix of the database.
Refer to this article for details on the process: https://access.redhat.com/site/node/125253

5. How would the customer like to achieve this? (List the functional requirements here)
This should be either a separate utility or a UI interface on the Portal available to the end user using RHEV. This utility would confirm that VM in question is actually not running on any of the hosts and it is safe to set its status to Down manually.
How to confirm this: (i) trust user confirmation (ii) implement the actual check. (i) can be used initially, same as "Confirm host was rebooted option"; (ii) can be implemented later.

6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented:
- Have a host with running VMs.
- Unplug the host from power and confirm VMs are not running.
- VMs would appear as Unknown on the portal.
- Run the utility and confirm: VMs move to "Down" state; Vms can start on other hosts.

7. Is there already an existing RFE upstream or in Red Hat Bugzilla?
I didn't find.

8. Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?
ASAP. RHEV3.3?

9. Is the sales team involved in this request and do they have any additional input?
NO.
But it will reduce the number of customer cases significantly and will make the product easier to manage.

10. List any affected packages or components.
ovirt-engine-backent

11. Would the customer be able to assist in testing this functionality if implemented?
Of course.
Comment 2 Itamar Heim 2013-06-21 02:15:48 EDT
marina - when do you need this that 'confirm host shutdown' didn't solve the issue (which makes it a bug)?
Comment 7 Itamar Heim 2013-06-24 05:14:30 EDT
closing this one since with bug bug 837539 we are not aware of a use case this is relevant for.
if there is a bug with VMs not moving from unknown on host status change, please open a specific bug.

Thanks,
   Itamar

Note You need to log in before you can comment on or make changes to this bug.