Bug 976643 - edit mode display is badly broken and almost impossible to use since 2.00-19 "Make grub fit better into the boot sequence, visually" patches (#966719)
edit mode display is badly broken and almost impossible to use since 2.00-19 ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
19
All All
unspecified Severity urgent
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
AcceptedFreezeException
:
Depends On:
Blocks: F19-accepted/F19FinalFreezeException
  Show dependency treegraph
 
Reported: 2013-06-21 01:34 EDT by Adam Williamson
Modified: 2013-06-21 22:30 EDT (History)
5 users (show)

See Also:
Fixed In Version: grub2-2.00-22.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-21 22:30:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of the bug (25.22 KB, image/png)
2013-06-21 01:34 EDT, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2013-06-21 01:34:54 EDT
Created attachment 763653 [details]
screenshot of the bug

If you try to edit a grub menu entry (say, to add '3' or 'nomodeset' or something...) with grub 2.00-19 or later, after the patches from https://bugzilla.redhat.com/show_bug.cgi?id=966719 , the display is badly messed up and very difficult to use (if you mess around enough you can kind of figure out what's going on, but it's a trial). See screenshot. Very easy to reproduce: install TC6, boot installed system, hit 'e' at the grub menu. Proposing as a final FE at least as it's an obvious problem for people who want to edit the boot menu, may be a blocker (I think we've taken similar issues as blockers before).
Comment 1 Adam Williamson 2013-06-21 12:49:26 EDT
I thought the problem was fairly obvious from the screenshot and easily reproducible, but apparently not, so to be clear, lines that wrap off the edge of the screen are not fully displayed. The cursor in the screenshot appears to be on a blank line, but it is actually in the middle of the 'linux' line that started above - the \ character marks where it should  be wrapped onto the next line (where the cursor is), but it is not displayed properly at all. Those three lines at the bottom of the screen are part of the chunk of text that should be displayed under the cursor, replicated three times for no apparent reason. When you type, *one* of them changes. I can include a screencast if you really need.
Comment 2 Fedora Update System 2013-06-21 14:59:29 EDT
grub2-2.00-22.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/grub2-2.00-22.fc19
Comment 3 Dan Mashal 2013-06-21 15:16:50 EDT
+1
Comment 4 Kevin Fenzi 2013-06-21 15:18:44 EDT
+1 FE definitely. I'm not sure it meets any blocker critera, but it really should be fixed. ;(
Comment 5 Adam Williamson 2013-06-21 15:20:03 EDT
That's +3 (counting me), and I know pjones is +1, so setting AcceptedFreezeException.
Comment 6 Adam Williamson 2013-06-21 18:35:11 EDT
Fix looks good in testing here.
Comment 7 Fedora Update System 2013-06-21 22:30:00 EDT
grub2-2.00-22.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.