Bug 976702 - dns.tsig.sign may fail in fips depending on used hash algorithm
dns.tsig.sign may fail in fips depending on used hash algorithm
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-dns (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Python Maintainers
BaseOS QE - Apps
:
Depends On:
Blocks: 839624
  Show dependency treegraph
 
Reported: 2013-06-21 04:20 EDT by Bohuslav "Slavek" Kabrda
Modified: 2014-06-17 08:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-17 08:50:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bohuslav "Slavek" Kabrda 2013-06-21 04:20:22 EDT
dns.tsig.sign may fail in fips depending on used hash algorithm (specifically with md5, which is unfortunately the default). The failure seems to be acceptable, since signing should be secure.
Comment 3 Bohuslav "Slavek" Kabrda 2014-06-17 08:50:39 EDT
Closing as wontfix - users are free to use a different algorithm - it is ok that this fails in FIPS if users choose to use MD5.

Note You need to log in before you can comment on or make changes to this bug.