Bug 976715 - Add grubby to @core so that minimal f20 rawhide installs boot
Add grubby to @core so that minimal f20 rawhide installs boot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-21 05:28 EDT by Jens Petersen
Modified: 2014-03-16 23:33 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-05 03:02:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of oops from virt-manager console (14.84 KB, image/png)
2013-06-21 05:28 EDT, Jens Petersen
no flags Details

  None (edit)
Description Jens Petersen 2013-06-21 05:28:42 EDT
Created attachment 763712 [details]
screenshot of oops from virt-manager console

Description of problem:
Yesterday I did a minimal install of Rawhide (via F19 TC6 netboot.iso)

Version-Release number of selected component (if applicable):
kernel-3.10.0-0.rc6.git0.4.fc20

How reproducible:
100%

Steps to Reproduce:
1. install minimal Rawhide
2. reboot

Actual results:
Oops - see above screenshoot

Expected results:
no crash
Comment 1 Josh Boyer 2013-06-21 09:13:48 EDT
The kernel can't find it's rootfs.  Most likely this is because it wasn't given an initramfs.  Look in /boot and make sure the corresponding initramfs- file exists, and if so make sure it's listed in the grub configuration file.
Comment 2 Jens Petersen 2013-07-02 00:48:20 EDT
Thanks

Right there is no initramfs in /boot, though I do see
/boot/<long-hash>/kernel-<version>-<release>.<arch>/initrd
Comment 3 Harald Hoyer 2013-07-02 05:38:39 EDT
you have to add grubby to the minimal install
Comment 4 Jens Petersen 2013-07-02 23:43:43 EDT
So should dracut require grubby?

Or do we add it to the @core group?
Comment 5 Harald Hoyer 2013-07-03 04:35:24 EDT
Add it to the @core group
Comment 6 Jens Petersen 2013-07-03 04:50:40 EDT
Okay given that grubby is apparently on the road to be deprecated
since it does not follow http://www.freedesktop.org/wiki/Specifications/BootLoaderSpec/
I will add it to @core for now and hopefully rawhide installs will
start to boot again. :)
Comment 8 Jens Petersen 2013-07-05 03:02:25 EDT
Minimal install of today's rawhide boots to login prompt.

Note You need to log in before you can comment on or make changes to this bug.