Bug 976719 - Move the openstack-nova-novncproxy subpackage from novnc to openstack-nova package
Move the openstack-nova-novncproxy subpackage from novnc to openstack-nova pa...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
3.0
Unspecified Unspecified
low Severity low
: Upstream M2
: 4.0
Assigned To: Xavier Queralt
Ami Jeain
:
Depends On:
Blocks: 982217 985519 985902 985912 1124330
  Show dependency treegraph
 
Reported: 2013-06-21 05:49 EDT by Nikola Dipanov
Modified: 2016-04-26 09:23 EDT (History)
12 users (show)

See Also:
Fixed In Version: openstack-nova-2013.2-0.8.b2.el6ost
Doc Type: Bug Fix
Doc Text:
The nova-novncproxy included with openstack-nova-novncproxy was previously packaged from the novnc component. Intermittent divergences between novnc and the upstream nova package required corresponding fixes to be backported. With this fix, nova-novncproxy has been subpackaged from the nova component. Divergences are now avoided, and future upstream fixes are integrated faster.
Story Points: ---
Clone Of:
: 985519 985902 985912 (view as bug list)
Environment:
Last Closed: 2013-12-19 19:07:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
move novnproxy to openstack-nova (9.55 KB, patch)
2013-07-12 04:03 EDT, Xavier Queralt
no flags Details | Diff
move novnproxy to openstack-nova (9.55 KB, patch)
2013-07-12 05:00 EDT, Xavier Queralt
no flags Details | Diff
remove novnproxy from novnc package (17.47 KB, patch)
2013-07-12 05:22 EDT, Xavier Queralt
ndipanov: review-
Details | Diff
remove novnproxy from novnc package (19.16 KB, patch)
2013-07-15 07:29 EDT, Xavier Queralt
xqueralt: review? (ndipanov)
pbrady: review-
Details | Diff
move novnproxy to openstack-nova (6.28 KB, patch)
2013-07-18 05:48 EDT, Xavier Queralt
pbrady: review+
Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2013:1859 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2013-12-20 19:01:48 EST

  None (edit)
Description Nikola Dipanov 2013-06-21 05:49:05 EDT
Description of problem:

This will simplify work that needs to be done around packaging.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 3 Xavier Queralt 2013-07-12 04:03:00 EDT
Created attachment 772570 [details]
move novnproxy to openstack-nova
Comment 4 Xavier Queralt 2013-07-12 05:00:11 EDT
Created attachment 772604 [details]
move novnproxy to openstack-nova
Comment 5 Xavier Queralt 2013-07-12 05:22:20 EDT
Created attachment 772611 [details]
remove novnproxy from novnc package
Comment 6 Xavier Queralt 2013-07-12 05:25:25 EDT
I've attached the patches with the changes for novnc and openstack-nova packages to move novncproxy to the last one.
Comment 7 Nikola Dipanov 2013-07-15 06:05:24 EDT
Comment on attachment 772611 [details]
remove novnproxy from novnc package

I believe we should also remove the novncproxy part of the manpage patch.
Comment 8 Xavier Queralt 2013-07-15 07:29:38 EDT
Created attachment 773701 [details]
remove novnproxy from novnc package

Removed novncproxy's man page
Comment 9 Pádraig Brady 2013-07-18 02:26:00 EDT
Comment on attachment 773701 [details]
remove novnproxy from novnc package

Actually we probably want /etc/sysconfig/openstack-nova-novncproxy stub included as %config(noreplace) so that config is updated appropriately rather than wiped
See: http://pkgs.fedoraproject.org/cgit/openstack-nova.git/commit/?h=el6-grizzly&id=f70bf6e4
Comment 10 Xavier Queralt 2013-07-18 05:48:40 EDT
Created attachment 775236 [details]
move novnproxy to openstack-nova

Mark /etc/sysconfig/openstack-nova-novncproxy as config(noreplace) in spec.
Comment 17 Ami Jeain 2013-12-04 05:38:20 EST
verified:

# rpm -qi openstack-nova-novncproxy
 Source RPM: openstack-nova-2013.2-5.el6ost.src.rpm
Comment 20 errata-xmlrpc 2013-12-19 19:07:57 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.