Bug 976799 - Slash escaping in add vault command on Windows
Slash escaping in add vault command on Windows
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity high
: ER7
: EAP 6.3.0
Assigned To: David Michael
Russell Dickenson
David Michael
: Documentation, EasyFix
Depends On: 1001688
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-21 09:39 EDT by kamitsunami
Modified: 2014-08-14 11:17 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Instance Name: Not Defined Build: CSProcessor Builder Version 1.8 Build Name: 11865, Administration and Configuration Guide-6.1-3 Build Date: 23-05-2013 10:40:22
Last Closed: 2014-06-28 11:24:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kamitsunami 2013-06-21 09:39:05 EDT
Title: Configure the JBoss Enterprise Application Platform to Use the Password Vault

Describe the issue:
In the documentation it supplies an example of the command to add a password vault in Linux.  I am using windows, so the file separator is "\" instead of "/".  This causes issues with some of the jboss-cli commands as the "\" need to be escaped.
In the case of the add vault command you must double escape the slashes, so "\" becomes "\\\\" (4 in total). 

Suggestions for improvement:
The escaping is fine, but can the documentation be updated to let users know this is a requirement when using Windows, it took me a while to figure out it was the escaping that was giving me problems with the command.

Additional information:
Comment 2 Misty Stanley-Jones 2013-08-20 03:37:05 EDT
I added the following in a note:

				<para>
					If you use Microsoft Windows, replace each <literal>/</literal> character in a filename or directory path with four <literal>\</literal> characters. This is because it should be two <literal>\</literal> characters, each escaped. This does not need to be done for other <literal>/</literal> characters.
				</para>

Let me know if this works for you.
Comment 3 Russell Dickenson 2013-08-25 22:58:27 EDT
The text has been corrected and it now available for QE at [1]. When validating this change, first confirm that you're viewing revision 1.0-58 or later.

[1] http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_JBoss_Enterprise_Application_Platform/6.1.1/html-single/Administration_and_Configuration_Guide/index.html#Configure_the_Enterprise_Application_Platform_to_Use_the_Password_Vault1
Comment 7 Josef Cacek 2014-06-05 09:34:57 EDT
Verification failed. The point 2 from comment #4 is still not fixed. (/ -> \)

Replace the current text with something like:

If you use Microsoft Windows Server, in the CLI command, escape each \ character in a directory path with an additional \ character (e.g. "C:\\data\\vault\\vault.keystore"). This is because single \ character is used for character escaping.
Comment 11 Ondrej Lukas 2014-06-11 07:06:30 EDT
Note from comment 7 was added. Verified on stage in Administration and Configuration Guide in Revision 6.3.0-24 and in Development Guide in Revision 6.3.0-20.

Note You need to log in before you can comment on or make changes to this bug.