Bug 976818 - USB 3.0 disk not found at boot
Summary: USB 3.0 disk not found at boot
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 18
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-21 14:29 UTC by Tom Horsley
Modified: 2013-06-26 16:26 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-26 16:26:22 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Complete dmesg output after power cycling disk drive (70.07 KB, text/plain)
2013-06-21 14:32 UTC, Tom Horsley
no flags Details
Complete /var/log/message from start of last boot (92.37 KB, text/plain)
2013-06-21 14:33 UTC, Tom Horsley
no flags Details

Description Tom Horsley 2013-06-21 14:29:38 UTC
Description of problem:
I have this USB 3.0 external drive:
Bus 004 Device 002: ID 1058:1130 Western Digital Technologies, Inc. 

It is plugged into a USB 3.0 port on my new Z87 based motherboard (asus sabertooth z87).

The drive is never recognized when I reboot the system. If I unplug the power and plug it back in after the system is up, the drive shows up again, and this
appears in dmesg:

[   97.829119] usb 4-6: new SuperSpeed USB device number 2 using xhci_hcd
[   97.841009] usb 4-6: New USB device found, idVendor=1058, idProduct=1130
[   97.841017] usb 4-6: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[   97.841023] usb 4-6: Product: My Book 1130
[   97.841027] usb 4-6: Manufacturer: Western Digital
[   97.841030] usb 4-6: SerialNumber: 574341563550333436303533
[   97.842380] scsi11 : usb-storage 4-6:1.0
[   99.828852] scsi 11:0:0:0: Direct-Access     WD       My Book 1130     1012 PQ: 0 ANSI: 6
[   99.829194] scsi 11:0:0:1: Enclosure         WD       SES Device       1012 PQ: 0 ANSI: 6
[   99.829440] sd 11:0:0:0: Attached scsi generic sg6 type 0
[   99.829566] scsi 11:0:0:1: Attached scsi generic sg7 type 13
[  109.656369] sd 11:0:0:0: [sdf] 1953458176 512-byte logical blocks: (1.00 TB/931 GiB)
[  109.656613] sd 11:0:0:0: [sdf] Write Protect is off
[  109.656616] sd 11:0:0:0: [sdf] Mode Sense: 47 00 10 08
[  109.656840] sd 11:0:0:0: [sdf] No Caching mode page present
[  109.656842] sd 11:0:0:0: [sdf] Assuming drive cache: write through
[  109.657876] sd 11:0:0:0: [sdf] No Caching mode page present
[  109.657877] sd 11:0:0:0: [sdf] Assuming drive cache: write through
[  109.663364]  sdf: sdf1
[  109.664605] sd 11:0:0:0: [sdf] No Caching mode page present
[  109.664606] sd 11:0:0:0: [sdf] Assuming drive cache: write through
[  109.664607] sd 11:0:0:0: [sdf] Attached SCSI disk
[  109.664849] ses 11:0:0:1: Attached Enclosure device

I have read about a bug with USB 3.0 driver and the early Z87 chipset (which I must have since the fixed chips aren't due till July), but this doesn't seem like that bug since I never suspend the system (unless maybe rebooting passes through the same sleep state for some reason), so I thought there might actually be a kernel bug in the new Z87 chipset support code and figured I'd report it.

Version-Release number of selected component (if applicable):
kernel-3.9.6-200.fc18.x86_64


How reproducible:
Every time I reboot, the disk has utterly vanished till I power cycle it and then it looks like it was just plugged in.

Steps to Reproduce:
1.see above
2.
3.

Actual results:
No disk device shows up at all

Expected results:
Disk device shows up.

Additional info:

Comment 1 Tom Horsley 2013-06-21 14:32:56 UTC
Created attachment 763871 [details]
Complete dmesg output after power cycling disk drive

Comment 2 Tom Horsley 2013-06-21 14:33:53 UTC
Created attachment 763872 [details]
Complete /var/log/message from start of last boot

Comment 3 Tom Horsley 2013-06-21 16:11:22 UTC
Just tried an experiment:

I shutdown my computer.

I power cycled the USB 3.0 disk drive.

I powered the computer back up.

Result: The drive was visible when the system booted.

So this does seem like something the system does to the drive on the way down (which also seems a lot like the Z87 hardware bug), but maybe there is some way to avoid telling the USB disks to go to sleep when I know I'm rebooting?

Comment 4 Tom Horsley 2013-06-26 16:26:22 UTC
OK, advice I got over on an intel forum to update the external drive's firmware seems to have fixed this, so I guess it is not a bug in the kernel.


Note You need to log in before you can comment on or make changes to this bug.